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Change History

Thistable lists changes made to this guide. Most recent changes appear at the top.

Change See Date

Added information about the PostlInstallation Tasks > Configure | October 2021
availability of case-insensitive the First Node

login IDs Postlnstall ation Tasks > Configure
the Second Node

Unified CCX Licenses> Obtaining
License MAC using Administrator
Web Interface

Initial Release of Document for Release 12.5(1) SU1

Added details about COPfile Unified CCX Upgrade>Preupgrade | January 2021
Tasks

Unified CCX Upgrade>COP File

Unified CCX Upgrade>COP
File>Apply COP File

Added the point about disabling | Unified CCX Upgrade>Important
SRTP before upgrade Considerations for Upgrade

Added a caution for installing Unified CCX Installation>Install
second node Unified CCX on Second Node
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Preface |
Il About This Guide

About This Guide

This guide explains the deployment options, how to install, upgrade, uninstall, and patch Unified CCX, and
how to change a Unified CCX deployment.

Audience
System installers and administrators or anyone who installs or configures Unified CCX and aUnified IPIVR
telephony system.
Conventions
This manual uses the following conventions.
Convention Description
boldface font Boldface font is used to indicate commands, such as

user entries, keys, buttons, and folder and submenu
names. For example:

¢ Choose Edit > Find
« Click Finish.

italic font Italic font is used to indicate the following:

 Tointroduce anew term. Example: A skill group
isacollection of agentswho share similar skills.

* For emphasis. Example: Do not use the
numerical naming convention.

« An argument for which you must supply values.
Example:
I F (condition, true-value, false-value)

* A book title. Example:

See the Cisco Unified Contact Center Express
Installation Guide.
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Related Documents .

Convention Description
wi ndowfont Window font, such as Courier, is used for the
following:

« Text asit appearsin code or information that the
system displays. Example:

<htm ><title> C sco Systens,Inc.
</title></htm >

« File names. Example:
tserver. properties.

« Directory paths. Example:
C:\ Program Fi | es\ Adobe

string Nonquoted sets of characters (strings) appear in
regular font. Do not use quotation marks around a
string or the string will include the quotation marks.

[] Optional elements appear in square brackets.

{x]y|z} Alternative keywords are grouped in braces and
separated by vertical bars.

[x]y]z] Optional alternative keywords are grouped in brackets
and separated by vertical bars.

<> Angle brackets are used to indicate the following:

« For arguments where the context does not allow
italic, such as ASCII output.

* A character string that the user enters but that
does not appear on the window such asa
password.

n The key labeled Control is represented in screen
displays by the symbol ~. For example, the screen
instruction to hold down the Control key while you
pressthe D key appears as”\D.

Related Documents

Document or Resource Link

Cisco Unified Contact Center Express | https.//www.cisco.com/en/US/products/sw/custcosw/ps1846/
Documentation Guide products_documentation_roadmaps _list.html

Cisco Unified CCX documentation https://www.cisco.com/en/U S/products/sw/custcosw/ps1846/tsd
products_support_series_ home.html

Cisco Unified Contact Center Express Install and Upgrade Guide, Release 12.5(1) SU1 .


https://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_documentation_roadmaps_list.html
https://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_documentation_roadmaps_list.html
https://www.cisco.com/en/US/products/sw/custcosw/ps1846/tsd_products_support_series_home.html
https://www.cisco.com/en/US/products/sw/custcosw/ps1846/tsd_products_support_series_home.html

. Documentation and Support
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Document or Resource

Link

Cisco Unified Intelligence Center
documentation

https.//www.cisco.com/en/US/products/ps9755/tsd_products
support_series_home.html

Cisco Finesse documentation

https://www.cisco.com/en/US/products/ps11324/tsd_products
support_series_home.html

Cisco Customer Collaboration Platform
documentation

From Unified CCX Release
12.5(1), CCP documents are
availableinthe Cisco Unified
CCX documentation folder.

Note

https.//www.cisco.com/en/U S/products/sw/custcosw/ps1846/tsd
products support_series_ home.html

Cisco Unified CCX Virtualization
Information

https://www.cisco.com/c/dam/en/us/td/docs/voice ip_comm/uc_
system/virtualization/
virtualizati on-ci sco-unified-contact-center-express.html

Cisco Unified CCX Compatibility
Information

https.//www.cisco.com/c/en/us/support/customer-col laboration/
unified-contact-center-express/
products-device-support-tables-list.html

Documentation and Support

To download documentation, submit a service request, and find additional information, see What's New in
Cisco Product Documentation at  https://www.cisco.com/en/US/docs/general /whatsnew/whatsnew.html.

Documentation Feedback

To provide your feedback for this document, send an email to:

contactcenterproducts_docfeedback@cisco.com
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CHAPTER 1

Installation Preparation

« Installation Scenarios, on page 1

 System Requirements, on page 2

« Important Considerations Before Installation, on page 2
* Preinstallation Tasks, on page 4

Installation Scenarios

Unified CCX installation has the following installation options:

« Standard installation - Thisoption allowsyou to install Unified CCX software from theinstallation disc.

* Unattended installation - This option allows you to use the installation disc and a preconfigured USB
disk to install Unified CCX software unattended.

* Virtualization - Unified CCX supportsinstallation on avirtual machine.

N

Note For moreinformation, see the Unified CCX Virtualization related information
located at: https.//www.cisco.com/c/dam/en/us/td/docs/voice ip_comm/uc
system/virtualization/virtualization-ci sco-unified-contact-center-express.html.

Table 1: Installation Scenarios

Installation Scenario

Tasks

Standalone (Single
Node) Setup

Standard Installation:
e Install Unified CCX from Installation DVD, on page 5

« Configure the First Node, on page 11

Unattended Installation:
« Perform Unattended Installation Using Answer File Generator, on page 8

« Configure the First Node, on page 11
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. System Requirements
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Installation Preparation |

Installation Scenario

Tasks

High Availability
(Two Node) Setup

Standard Installation:
« Install Unified CCX from Installation DVD, on page 5

« Configure the First Node, on page 11
* Add Second Node, on page 6
« Install Unified CCX on Second Node, on page 7

« Configure the Second Node, on page 12

Unattended Installation:
« Perform Unattended Installation Using Answer File Generator, on page 8

« Configure the First Node, on page 11

« Add Second Node, on page 6

* Perform Unattended Installation Using Answer File Generator, on page 8
« Configure the Second Node, on page 12

Note

System Requirements

For information about system requirements, see the Unified CCX Compatibility related information located
at:

\}

You can use the Cisco Prime Collaboration Deployment application also to install your cluster. For more
information, see Cisco Prime Collaboration Deployment Administration Guide.

https://www.cisco.com/c/en/us/support/customer-col laborati on/unified-contact-center-express/
products-device-support-tables-list.html

Note

For more information about VMware ESXi's that are supported, refer to the Mirtualization for Cisco Unified
Contact Center Express.

Important Considerations Before Installation

Read the following information carefully before you proceed with the installation:

« For 100 agent profile, if you want to deploy Cloud Connect on the BE600O, you must configure 14GB
of VRAM. For 400 agent profile, you must use the new OVA for which, you must configure 20GB of

VRAM.
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Important Considerations Before Installation .

A\

Note Ensurethat the reservation of CPU and memory adhere to the specifications
mentioned in the Virtualization Wiki.

* Unified CCX can only beinstalled on virtual machines and not on bare metal servers.

* DNS configuration and domain fields are mandatory for Unified CCX installation. Both forward and
reverse lookups are required. DNS is required for the Unified CCX Chat feature to function and for
integration with ICM by hostnamein Unified IP IVR.

» When you Install Unified CCX on an existing server formats the hard drive, it overwrites all existing
data on the drive. It also upgrades the system BIOS, firmware, and Redundant Array of Inexpensive
Disks (RAID) configuration if they are outdated.

* Ensure that you connect each Unified CCX node to an uninterrupted power supply (UPS). This protects
the Unified CCX server from unexpected power failure that damages the physical media.

* All serversin acluster must run the samerelease of Unified CCX. The only exception iswhile upgrading
cluster software, during which atemporary mismatch is allowed.

« Configure the server by using a static | P address so that the server | P address remains unchanged.
« Do not attempt to perform any configuration tasks during the installation.

* Thefield values (namely hostname and passwords) that you enter while you are running the installation
program are case-sensitive. Hostname must be in lower case and the character limit is 24 characters.

« Ensure that the administrator username is not the same as that of any end user in CUCM.

» When you insert or remove a USB drive, you might see error messages on the console similar to “sdb:
assuming drive cache: write through.” You can safely ignore these messages.

« Ensure that the third-party web services support TLS version 1.2 before you integrate any third-party
web services.

« After the installation of Unified CCX, you have to select appropriate Smart License Type. For Smart
Licensing details, see Cisco Unified Contact Center Express Features Guide.

* When creating the OS Administrator ID, ensure that it does not start with “uccx” or “UCCX” because
such I1Ds conflict with system account names that are used internally within the Unified CCX server.
Ensure that the OS Administration password is at least six characterslong; it can contain alphanumeric
characters, hyphens, and underscores. For more information about OS Administrator username and
password restrictions, see Server Configuration Table, on page 35.

* Ensure that the Application User password is at least six characterslong; it can contain a phanumeric
characters, hyphens, and underscores. For moreinformation about Application User password restrictions,
see Server Configuration Table, on page 35.
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Installation Preparation |

Preinstallation Tasks

Step 1

Step 2
Step 3

Step 4

Step 5

Procedure

If the system time is from an Network Time Protocol (NTP) server (mandatory for VMware deployments),
verify that the first node synchronizes with the NTP server before you install a second node.

Note If the first node fails to synchronize with an NTP server, installation of a second node also fails.

If thefirewall isin the routing path, disable the firewall between nodes. Increase the firewall timeout settings
until you complete the installation.

Record the network interface card (NIC) speed and duplex settings of the switch port to which you will connect
the new server.

Enable PortFast on al switch ports that are connected to Cisco servers.

Caution Do not run Network Address Translation (NAT) or Port Address Translation (PAT) between Unified
CCX nodes.

If you choose to apply a patch during installation, use a Secure File Transfer Protocol (SFTP) server that is
certified by Cisco through the Cisco Technology Developer Partner program (CTDP). For more information
about Supported SFTP Servers, see System Requirements section in Cisco Unified Contact Center Express
Admin and Operations Guide.
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CHAPTER 2

Unified CCX Installation

« Install Unified CCX from Installation DV D, on page 5
» Add Second Node, on page 6

« Install Unified CCX on Second Node, on page 7

* Unattended Installation, on page 7

« Service Update During Installation, on page 8

Install Unified CCX from Installation DVD

Step 1
Step 2

Step 3

Step 4

To install Unified CCX from an installation DV D, perform the following steps:

Procedure

Boot from the installation DV D.

Theinstaller checks the integrity of the DVD before beginning installation. Click Yesto perform a media
check.

a) If the mediacheck fails, create another DVD.
b) If the mediacheck passes, click OK to proceed with installation.

Follow the instructions on the screen. When the Apply Patch window appears, select No to begin the basic
installation.

Note If you want to perform aservice upgrade by applying patch, see Service Update During I nstallation.

Follow the instructions on the screen to complete the installation. Use the information from Server
Configuration Information for Installation to enter the basic configuration information that is required
during installation.

What to do next
Configure the First Node, on page 11
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[ Add Second Node

\)

Note If you areinstalling on second node, configure first node and then add second node.

Related Topics
Service Update During Installation, on page 8
Server Configuration Information for Installation, on page 35

Add Second Node

Configure the IP address of the second node on the first node.

)

Note If you are using Smart Licensing and have already registered the first node with Cisco SSM, ensure that you
have purchased HA license. Else, the product instance will be moved to out-of-compliance state.

Procedure

Step 1 Logintothe Cisco Unified CCX Administration web interface of the first node.

Step 2 Choose System > Server.

Step 3 Click Add New.

Step 4 Enter the | P address or the host name of the second node in the Host Name/I P Address field.

Note When anew Unified CCX nodeis added , the Customer Collaboration Platform Configurations

must be saved again in the Subsystems menu of Cisco Unified Contact Center Express
Administration. This enables the change to take effect to re-create al the notifications for email
and chat in Customer Collaboration Platform. For more details on this, see the guide at

https://www.ci sco.com/c/en/us/support/customer-collaborati on/unified-contact-center-express/
products-maintenance-guides-list.html.

Step 5 Enter the IPv6 Addressin | Pv6 Address (for dual | Pv4/I Pv6) field.
Step 6 Enter the MAC address detailsin the MAC Addressfield.
Step 7 Click ADD.

What to do next
Install Unified CCX on Second Node, on page 7

Related Topics
Server Configuration Information for Installation, on page 35
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Install Unified CCX on Second Node .

Install Unified CCX on Second Node

Perform the following steps to install Unified CCX on the second node in the cluster:

)

Note Perform thisinstallation during off-peak hours to avoid possible dropped calls during the formation of a
cluster.

Procedure

Step 1 Verify that the first node is synchronized with an NTP server.
a) Fromthe CLI onthefirst node, enter utils ntp status. The output indicates the synchronization state.

Note If the first nodeis not synchronized with an NTP server, installation of the second node fails.

Step 2 Install Unified CCX on the second node using the procedure Install Unified CCX from Installation DVD, on
page 5. The system checks that the second node connects to the first node during the installation.

Note a. If you have configured an SMTP server for the first node, you must configure it for the second
node also.

b. During theinstallation procedure, when you are prompted to enter the administrator user name
and password, enter the administrator user name and password that you set up in the first node
of Unified CCX. Otherwise, the installation fails.

Caution After installing Unified CCX on the second node, configure it immediately. Until the second node
is configured, do not change the security password or enable FIPS 140-2 mode on the first node.

What to do next
Configure the Second Node, on page 12

Related Topics
Server Configuration Information for Installation, on page 35

Unattended Installation

Unified Communications Answer File Generator generates answer filesfor unattended installations of Unified
CCX 11.6(1) or later. Goto https://www.cisco.com/c/en/us/applicat/content/cuc-af g/index.html (Cisco Unified
Communications Answer File Generator web page) for details on the Answer File Generator.

The Answer File Generator supports the following features:

« Allows simultaneous generation and saving of answer files for unattended installation on the publisher
node and the subscriber node.
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Unified CCX Installation |
. Perform Unattended Installation Using Answer File Generator

* Provides syntactical validation of data entries.

* Provides online help and documentation.

)

Note 1. Unattended installation supports only basic installations and not the upgrades.

2. UseaUSB disk that is preformatted to be compatible with Linux 2.6 for the configuration file. This key
has a FAT32 format.

Related Topics
Server Configuration Information for Installation, on page 35

Perform Unattended Installation Using Answer File Generator

Procedure

Step 1 Go to https://www.cisco.com/c/en/us/applicat/content/cuc-af g/index.html (Cisco Unified Communications
Answer File Generator web page).

Step 2 Savethepl at f or nConf i g. xm fileto aLinux-compatible USB drive.
Step 3 Plug in the USB drive to the server on which you will install Unified CCX.
Step 4 Follow theinstructionsin Install Unified CCX from Installation DVD, on page 5.

Related Topics
Server Configuration Information for Installation, on page 35

Service Update During Installation

During the installation process, you can upgrade the version that is contained on the installation disc with a
later Service Update (SU). If you click Yesin the Apply Patch window, the installation wizard installs from
the DV D, restarts the system, and then applies the patch. You can access the SU patch from the following
SOUrces:

* LOCAL—Retrievesthe upgrade file from alocal DVD.
» SFTP—Retrieves the upgrade file from aremote server by using Secure File Transfer Protocol (SFTP).

» FTP—Retrieves the upgrade file from a remote server by using File Transfer Protocol (FTP).

Apply Service Update
Y

Note For an HA setup, repeat this procedure on node 2.
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| Unified CCX Installation

Step 1

Step 2
Step 3

Step 4

Step 5

Apply Service Update .

Before you begin
To upgrade from a DVD:

1. Download the appropriate upgrade file from www.cisco.com.

2. Create an 1SO image of the upgrade file on the DV D. Do not copy the ISO fileto aDVD.

Toupgrade from an FTP/SFTP server:

1. Download the appropriate upgrade file from www.cisco.com.

2. Placethe upgrade file on a supported FTP/SFTP server to which your server has access.

Procedure

During the installation procedure, when asked whether to apply a patch, choose Yesin the Apply Patch
window. For more information about UCCX installation, see I nstall Unified CCX from Installation DVD.

Choose source as SFTP or FTP or LOCAL, and click OK.
Enter the patch directory and patch name, and click OK.

Option Description

Linux or UNIX Server Enter aperiod (.) followed by aforward slash (/) at the beginning of the directory
path.

Example: ./patches

Windows Server  Begin the path with aforward slash and use forward slashes throughout
the path.

« Start the path from the FTP or SFTP root directory on the server. Do not
enter aWindows absolute path, which startswith adrive | etter; for example,
“ C: n i

Example: /patches

Click Continueto apply the patch.
The system installs the patch and restarts the server.

Once the server has rebooted after patch installation, choose Proceed to continue the installation or Cancel
to stop the installation.

Related Topics
Install Unified CCX from Installation DVD, on page 5
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CHAPTER 3

Postinstallation Tasks

« Configure the First Node, on page 11

* Configure the Second Node, on page 12

* Configure Network Protocol for the Unified Intelligence Center Cluster , on page 13
* Switch Network Deployment from LAN to WAN, on page 13

« Upload Self-Signed Certificate, on page 14

Configure the First Node

Before you begin
After a successful installation, perform one of the following:

« If the Cisco Unified Communications Manager (CUCM) cluster is using the self-signed certificate, upload
Tomcat certificates from al the nodes of CUCM cluster into the Unified CCX Tomcat trust store. To
upload certificates, use the Cisco Unified OS Administration interface (for example,
htt ps:// <uccx-host name>/ cnpl at f or m) or theset cert inport trust toncat CLI.

« If the Cisco Unified Communications Manager (CUCM) cluster isusing the CA signed certificate, upload
theroot CA certificate into Unified CCX Tomcat trust store.

Verify that the following users are added in Unified Communications Manager application:

« Unified CM Users - These are end users in Unified Communications Manager, who are assigned in
Unified CCX asadministrators. Using administrator credentials, you can login to the foll owing components
for Unified CCX:

* Unified CCX Application Administration

* Cisco Unified CCX Serviceability

* Cisco Finesse Administration

» Cisco Unified Intelligence Center Administration
» Cisco I dentity Service

These users are required to integrate Unified Communications Manager with Unified CCX. For information
on adding Unified CM users, see topic "Adding Usersto a User Group" under the “User Management
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. Configure the Second Node

Step 1

Step 2

Configuration” section and “User Group Configuration” sub section in the Cisco Unified Communications
Manager Administration Guide at:

https.//ww.cisco.com/c/en/us/support/unified-communi cati ons/unified-communi cati ons-manager-cal Imanager/
products-maintenance-guides-list.ntml.

Procedure

Loginto Cisco Unified CCX Administration page on the first node to initiate the configuration using the
following URL format:

http://<servername or | P address>/appadnin

Note Use the credentials entered for Appl i cati on User Nane and Application User
Passwor d during installation.

User IDs are case-sensitive when logging into the Unified CCX Administration web interface. To
make them case-insensitive, you must install 12.5(1) SU1 ES02.

Follow instructions on the screen to complete the configurations.

Note Usethe credentials of the Unified Communications Manager End User having administrator privileges
in Unified CCX to configure the application users (AXL users).

What to do next
Add Second Node, on page 6

Configure the Second Node

Step 1

Step 2
Step 3

Restart node 1 followed by node 2 before initiating the configuration.

Procedure

Loginto Cisco Unified CCX Administration page of the second node to initiate the configuration.

Note Use the credentials entered for Appl i cati on User Nane and Application User
Passwor d during installation.

User IDs are case-sensitive when logging into the Unified CCX Administration web interface. To
make them case-insensitive, you must install 12.5(1) SU1 ESO2.

In the Welcome to Unified CCX Replication Wizard page, enter values for all the fields and click Next.
In the Component Activation page, wait until al the components get activated and then click Next.

If you have selected Networ k Deployment TypeasLAN, the Cisco Unified CCX Setup Result I nfor mation
page gets displayed.
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Step 4 If you have selected Networ k Deployment Type as WAN, enter appropriate values in Cisco Unified CM
Configuration page. Follow the instructions on the screen to compl ete the configurations.

Step 5 Restart the first node and then restart the second node.

Configure Network Protocol for the Unified Intelligence Center
Cluster

Cisco Unified Intelligence Center supports Multicast and TCP/IP as the network protocol. The default
configuration is Multicast.

If Unified CCX isinan HA over WAN deployment where Multicast is not supported, then the following CLI
command must be executed to configure the network protocol to TCF/IP:

* utilscuic cluster modetcp-ip

The CLI must be executed on both the nodes of the Unified Intelligence Center. Restart the Cisco Unified
Intelligence Center Service for the changes to take effect. To view the latest settings, you can execute the
following CLI commands:

« utils cuic cluster show

Switch Network Deployment from LAN to WAN

You can change a LAN-based two-node setup to work over WAN. To change the network deployment from
LAN to WAN for atwo-node setup, do the following:

Procedure

Step 1 Log in to the first node using the Unified CCX Administration web interface.
Step 2 Choose System > Server, and delete the second node from the list.

Step 3 Add the second node details again on the first node. See Add Second Node.
Step 4 Reinstall node 2. See Install Unified CCX on Second Node

Step 5 Configure the second node, and select the Networ k Deployment Type as WAN. See Configure Second
Node.

Step 6 Add or configure new Unified Communications Manager Telephony Call Control Groups for the second
node.

For more information, see the Unified CM Telephony Call Control Group configuration section in Cisco
Unified Contact Center Express Admin and Operations Guide.
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. Upload Self-Signed Certificate

Upload Self-Signed Certificate

The following procedure is an example for uploading the CUCM self-signed certificate to Unified CCX

)

Tomcat trust store.

Postinstallation Tasks |

Note

Step 1
Step 2

Step 3

Step 4
Step 5

The same procedure can be followed to upload CCP and Standalone CUIC self-signed certificates.

Procedure

Log in to Cisco Unified OS Platform CLI using administrator credentials.

Enter the show cert own tomcat command to view the CUCM certificate details.

The CUCM certificate is displayed.

Copy the certificate information starting from- - - - - BEG N CERTI FI CATE- - - - - to
and press Enter.

Example:
A sample certificate is as follows:

----- BEG N CERTI FI CATE- - - - -

M | D+TCCAUGgAW BAgl QRVNGT nHt bGarlnNgJ 1pCf TANBgkghki GOwOBAQs FADBL
M5 WCQYDVQQGEW J Tj EOMAWGALUECGWFQDI TQO8x Dj AVBgNVBAS MBUNCQUI VVRAW
HAYDVQQDDBVsb2FkdWN eCluMs5j aXNj by5j b20x Ej AQBgNVBAgMCUt BUK5BVEFL
QTESMBAGAL UEBWWJI Gk FOROFMTI'1J FMB4XDTI wMIAxM A2NDQz N1oXDTl yMIAxM A2
NDQz NI owd TEL MAk GA1UEBhMCSU4x Dj AMBg NVBAo MBUNJ U0 NPMUAWDAYDVQQL DAVD
kFCVTEe MBWGALUEAWWD@hZHV] Y3gt bj EuY2l zY28uY29t MRl wEAYDVQQ DAl L
QVJ OQVRBSOEX Ej AQBgNVBAC MCUJ BTkdBTE9SRTCCAS| wDQYJKoZI hvc NAQEBBQAD
ggEPADCCAQuCggEBAMPL3K6Y C5i 7n/ Ki dl pae3KMoet 7BASV+I TOX7Wz9OV6M+-U
r QJPsSryN DMWMe UFf pY4pxaA5KDAHgh5pz W 887 c 7nmVEZI gb+t Jut bed EFeP
Q AbBLhLRYMG My gppVANT v YWRCDCQF aOVMUDTFACLFt F4xxyJ| +ov3AdRuHew7b
rwlwsnhl 2dR3z/ 0CI53wN5nmdPnmBEd83n5L1 xLEH3HZBf f z3anuJeHKkJgOTpTdd+
t WR3I Ou/ URaKcpci 9q06h6bW BnpYt M hScYnS0ZuqVU0aOlZa7e7C+v4/ CS1r OY
usnl QuLDZv/ i Vf uxcEOMbS8eqPxt H+0x4eK5| zECAWEAAaOBhDCBg TALBgNVH®@BE
BAMCAr QWHQYDVRO! BBYWFAY! KwYBBQUHAWEGCCs GAQUFBWMCVBO GAL Ud Dy QUBBTt

j I xZBx6x+k6r Z0zaq4PA+j WHz ASBgNVHRVBAF 8 ECDAGAQH AgEAMCAGALUdEQQZ
MBe CFVWv YVRLY2N4LWix LiNpc 2Nv L\v b TANBgk ghki GOWOBAQs FAAOCAQEAghe+
B3dukli nR5pnz| Wij KvYYmACt NeAn9t RYI K2Bi j KV6a0qDuZwSpNOdGbl Rr OepRI

t hf kZvQGDz 05VZ45nmVf x| a+wx T3Ur f nsoi Knmc XBdaYhSs EoKbmA HbsxwSkl RWh
nZat xwgl XTI uPbF5F9wWJ STHTTwPk 3P0pj ZENF09S5hY/ x DEM/wf Or nKUETHIJPt s
z4LAr PgdaFbmAy8YLCp1YBcO 9mdxQnUUn4di n6GNv5c9BYDKet PWKHhX8Hr 7gC2
RTyBJc9t nhGALj DOykokeSp+5u77Xug9ZCt Agi | i HZu7cWhQu9l RToi Fkl gah23+
XbRBY! ZpCbv7r d6Hb Q==

----- END CERTI FI CATE- - - - -

Log into Unified CCX CLI using administrator credentials.

END CERTI FI CATE- - - - -

Enter the set cert import trust tomcat command to provide the CUCM certificate details.

a) Paste the copied CUCM certificate details and press Ret ur n.
The CUCM certificate isimported to Unified CCX Tomcat trust store.
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CHAPTER 4

Unified CCX Upgrade

« Unified CCX Upgrade Types, on page 15

« Important Considerations for Upgrade, on page 16

* Preupgrade Tasks, on page 19

« Unified CCX Upgrade Scenarios, on page 19

* COP File, on page 22

 Upgrade Unified CCX Using Web Interface, on page 22

* Upgrade Unified CCX Using CLI, on page 23

 Upgrade VMware Toals, on page 24

« Change NIC Adapter Type, on page 25

* Check and Perform Switch Version, on page 26

* Verify Version of Unified CCX, on page 27

* Verify Status of Services, on page 27

« Verify Unified CCX Database Replication, on page 28

* Verify Cisco Database Replication, on page 28

* Upgrade Unified CCX Editor, on page 29

« Launch Unified CCX Editor, on page 29

« Install Unified CCX Real-Time Monitoring Tool, on page 30
« Launch Unified CCX Real-Time Reporting Tool, on page 30

Unified CCX Upgrade Types

You can upgrade to Unified CCX version 12.5.1 SU1 from only Unified CCX versions 11.6.x, 12.0, and
12.5.1. If you are using any prior release of Unified CCX, you have to upgrade to 11.6.x or 12.0 and then
upgradeto 12.5.1 SU1.

Table 2: Upgrade Details

Upgrade File Type Upgrade Method Apply Upgrade From Note
SO Image e Command Line e Local DVD Thelocal DVD may bea
Interface (CLI1) bootable ISO image or a

. . * FTPISFTPserver | non hootable 1SO image.
« Cisco Unified OS
Administration Web

Interface
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\)

Note « Thereis service interruption during the upgrade and subsequent server restart.

» The new version isinstalled on the inactive partition.

« For moreinformation on supported component versions and browsers, seethe Unified CCX Compatibility
related information located at https.//www.cisco.com/c/en/us/support/customer-collaboration/
unified-contact-center-express/products-device-support-tables-list.html

\}

Note You can use the Cisco Prime Collaboration Deployment application also to upgrade your cluster. For more
information, see Cisco Prime Collaboration Deployment Administration Guide.

Important Considerations for Upgrade

» To manage your license better, migrate to smart Licensing. For moreinformation about Smart Licensing,
see Cisco Unified Contact Center Express Features Guide.

If you want to continue using Cisco WFO, you must remain on Classic Licensing as Cisco WFO does
not support Smart Licensing.

« For a 100 agent profile, if you want to deploy Cloud Connect, you must configure 14GB of vVRAM. For
a 400 agent profile, you must configure 20GB of vVRAM.

A

Note * A 300 agent profile is not available. You cannot switch versions.

« For a 100 agent profile, if you do not want to deploy Cloud Connect, there
isno change.

« Ensure that the reservation of CPU and memory adhere to the specifications
mentioned in the Virtualization Wiki.

* Install Unified CCX only on virtual machines. Unified CCX will not run on bare metal.
* In the virtual machine, change the Guest OS version to match the OS version of Unified CCX.

« DNSis mandatory. Before you upgrade, configure the domain name and DNS server | Ps and ensure the
forward and reverse lookups on the DNS server are correct.

» Do not make any configuration changes during upgrade because changes are lost after upgrade.
* Always ensure to perform the backup on the first node before you start upgrading the second node.

 Upgrade Unified CCX during off-peak hours or during a maintenance window to avoid service
interruptions.
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* Inan HA deployment of Unified CCX, you must switch both the Unified CCX nodesto the newer version
during the same maintenance window.

If the contact center is expected to function with only the first node that is switched to the new version,
ensure that the following conditions are met until the switch version on the second node is complete:

» No agents are logged in to the second node.

* The services, Cisco Finesse Tomcat, Cisco Unified CCX Engine, and Cisco Unified CCX
Database are in Stopped state on the second node.

« Upgrade Unified CCX and Cisco Customer Collaboration Platform in the same maintenance window
and perform the upgrade on Cisco Customer Collaboration Platform first, followed by Unified CCX.

« After the upgrade of Cisco Customer Collaboration Platform, unread and unhandled emails are downl oaded
from the mail server and added to Unified CCX. However, the draft emails are not downloaded.

* Ensure that avalid Cisco Customer Collaboration Platform OVA is deployed for a successful install or
upgrade. The upgrade stopsif no Cisco Customer Collaboration Platform OVA isfound in the deployment.

* Both the nodes in a cluster must run the same release of Unified CCX. The only exception is while you
are upgrading the cluster software, during which atemporary mismatch is allowed.

» Upgrade VMware tools and change the NI C adapter type for Unified CCX after the refresh upgrade and
before initiating the switch version.

« For more information on Certificates, see Cisco Unified Contact Center Certificate Management Guide
available at: https://www.cisco.com/c/en/us/support/docs/customer-collaboration/
unified-contact-center-express/118855-configure-uccx-00.html.

« Unified CCX 10.0(1) and later versionsinclude afeature in the VMware I nstallation information line to
indicateif the disk partitions are aligned. For aligned disk partitions, the VMware installation information
lineindicates"Partitionsaligned”. After upgrading, if theVVMwareinstallation information lineindicates
"ERROR-UNSUPPORTED: Partitions unaligned.”, it means that Cisco cannot provide support for any
performanceissues. To correct avirtual machinewith unaligned partitions, you must perform the applicable
restore (with rebuild) scenario procedure in Unified CCX Administration. For more information, see
Cisco Unified Contact Center Express Admin and Operations Guide.

« After the upgrade, the OS Administration lists the manually uploaded third-party CA certificates but
does not list the third-party CA certificates that are packaged with Unified CCX.

« If any Unified Intelligence Center user was made an Administrator using the utils cuic user make-admin
[user-name] command before an upgrade of Unified CCX, the user loses the Cisco Cisco Unified
Intelligence Center Administrator capabilities after the upgrade. Executethe CLI again, after the upgrade,
to make the user a Cisco Unified Intelligence Center Administrator.

« In an HA setup, do not switch versions on both the first and second nodes at the same time.

* When you upgrade Unified CCX in an HA deployment, ensure that the following conditions are met
before the switch version isinitiated on Node 2:

« If you have upgraded Node 1 to a new version and then reinstalled Node 2 with an older version,
you must upgrade Node 1 and Node 2 again to the new version, before you start the switch version.

* The switch version of Node 1 is complete and the node is successfully restarted. Otherwise, the
upgrade might fail or there might be discrepancy in data.
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A\

Note The switch version of Node 1 automatically initiates a node restart and there is
no need to manually restart Node 1.

* Ensure that you are able to log in successfully to Cisco Unified Intelligence Center, on Node 1,
using the Administrator or Reporting User credentials.

* You may experience a delay of approximately 30 minutes for the services to start during the first restart
of the Unified CCX system after switching the version. Thisis due to the application of security policies
after upgrade. This delay will not appear in subsequent restarts.

Do not modify the Hostname or |P address of the Unified CCX server during the upgrade process.

« After the upgrade of Unified CCX, agents and supervisors must clear the browser cache and cookies
before logging in to the Cisco Finesse Desktop and the Cisco Unified Intelligence Center.

* After asuccessful installation or upgrade, download and install the language pack COP to use the Cisco
Unified Intelligence Center interface and the Cisco Finesse Desktop interface in alanguage other than
English.

« After the upgrade, you must manually remove the Context Service gadget from the Cisco Finesse desktop
(Desktop Layout and Team Desktop Layout).

« After the upgrade of Unified CCX, if necessary, the administrator can copy the sample configurations
for customizing desktop propertiesfrom the View Default L ayout (Cisco Finesse Administration console
> Desktop Layout) and add to the respective custom layouts.

For more information, see the Upgrade section in the Cisco Finesse Installation and Upgrade Guide at
https://www.ci sco.com/c/en/us/support/customer-col l aboration/finesse/
products-installation-guides-list.html.

« After the upgrade, you can move to Smart Licensing. For Smart Licensing details, see Cisco Unified
Contact Center Express Features Guide.

» From Unified CCX Release 12.5(1) SU1, the connection between RmCm Subsystem and Unified CM
can be secured by enabling Secure Real-Time Transport Protocol (SRTP) in AppAdmin. If you had
enabled SRTP before upgrading to Unified CCX Release 12.5(1) SU1, disable and enable it again after
upgrade. Otherwise, the connection between RmCm Subsystem and Unified CM will not be secure.

* When SRTPisenabled in Unified CCX release 12.5(1), after upgrading to Unified CCX release 12.5(1)
SU1, the RmCm subsystem will be out of service on the subscriber node. Disable and enable SRTP again
to operate Unified CCX in SRTP-enabled mode.

* When SRTPisenabled in Unified CCX release 12.5(1) SU1, if you switch back to Unified CCX release
12.5(1), the RmCm subsystem will be out of service on both the nodes. Disable and enable SRTP again
to operate Unified CCX in SRTP-enabled mode.
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Preupgrade Tasks .

Preupgrade Tasks

Step 1
Step 2

Step 3

Step 4
Step 5
Step 6

Step 7

Step 8

Procedure

Obtain the ISO filefromht t ps: / / www. ci sco. com
Create an 1SO image of the upgrade file and place it on aDVD or FTP/SFTP server as required.

a) Create an |SO image of the upgrade file on the DVD. Do not copy the ISO fileto aDVD.
b) Placethe SO image on an FTP/SFTP server to which your server has access.

Obtain the license file. See Unified CCX Licenses.

Note You require the license file only if you continue to use Classic Licensing.

Back up al the existing data. For more information, see Cisco Unified Contact Center Express Admin and

Operations Guide.

In the Unified CCX Administration, navigate to Tools > Password M anagement. Ensure that the passwords

are the same in both the nodes.

Upload Customer Collaboration Platform certificate to the Unified CCX Tomcat trust store using the Cisco

Unified OS Administration interface. You can also usetheset cert inmport trust toncat CLI.

Perform one of the following:

a) If the Cisco Unified Communications Manager (CUCM) cluster isusing the self-signed certificate, upload
the Tomcat certificates from al the nodes of the CUCM cluster to the Unified CCX Tomcat trust store.
To upload certificates, use the Cisco Unified OS Administration interface (for example,
htt ps:// <uccx-host name>/ cnpl at f or m) or theset cert inport trust toncat CLI.

b) If the Cisco Unified Communications Manager (CUCM) cluster is using a CA-signed certificate, upload
the root and the intermediate CA certificates to the Unified CCX Tomcat trust store.

Install the following COP files.

a) Unified CCX - ucos.keymanagement.cop.sgn

b) CCP - ciscoccp.keymanagement.cop.sgn, if upgrading from Customer Collaboration Platform (CCP)
Release 12.5(1)
¢) SociaMiner - ciscosm.keymanagement.cop.sgn, if upgrading from SociaMiner Release 11.6(2) or 12.0(1)

For information about installing the COP files, see COP File, on page 22.
Note If you do not install these COP files, the upgrade fails.

Unified CCX Upgrade Scenarios

The following table lists the required tasks to upgrade a Single Node and a High Availability (HA) setup for
Refresh Upgrade and Linux to Linux Upgrade types.
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\)

Note During Refresh Upgradeto Release12.5.1 SU1, thesyst ent hi st ory. | og filemay containthefollowing
information, which can be ignored:

Switch Version 12.5.1.11001- XY to 12.0.1.10000-24 Aborted
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Table 3: Upgrade Scenarios

Upgrade Scenario Tasks

11.6.x/11.6.xSUx/12.0/12.5.1 t0 12.5.1 SU1 Single Node Setup:

1. Upgrade Unified CCX Using Web Interface, on
page 22 Or Upgrade Unified CCX Using CLI,
on page 23

2. Verify Version of Unified CCX, on page 27
3. Verify Status of Services, on page 27

HA Setup:

1. Upgrade Unified CCX Using Web Interface, on
page 22 or Upgrade Unified CCX Using CLI,
on page 23.

a. Upgrade the first node.

Check all the servicesin the first Node from
CLI and GUI and ensure that all the services
arein Good/In_Service state.

b. Upgrade the second node.

2. Check and Perform Switch Version.

Note Check all the servicesinthefirst Node
from CLI and GUI and ensure that all
the services are in Good/In_Service
state.

a. Perform switch version on the first node.

b. Perform switch version on the second node.

Note After the switch version is complete
on the second node, open the Unified
CCX Administration page of thefirst
nodeto check if the pageisrequesting
for alicense. Provide the license on
the first node.

3. Verify Version of Unified CCX, on page 27
4, Verify Status of Services, on page 27

5. Verify Unified CCX Database Replication, on
page 28
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COP File

Unified CCX Upgrade |

The COPfileisthe Cisco Options Packagefile. It isacompressed TAR file or an RPM filethat hasacop. sgn
file extension, and is signed by Cisco. COP files are installed on the active partition. You can apply the COP
fileusingthe CLI. The COPfilesfor aspecific release version can be downloaded from the location, Download
Software. (For example, browseto Unified Contact Center Express Upgrade Utilitiesfor a specific release
version from the following location, Products > Customer Collaboration > Contact Center Solutions>
Unified Contact Center Express).

Apply COP File

"
P

Attention

"
A

See the documentation that is provided with the COP file for additional instructions on how to apply the COP
file

Attention

\}

Contact Cisco if you want to roll back the COP file.

Note

Step 1
Step 2

For an HA setup, repeat this procedurefor node 2 only after restarting node 1 after successful COP installation.

Before you begin

1. Placethe COPfile on an FTP/STFP server to which your server has access.

Procedure

Follow Steps 1 to 8 from Upgrade Unified CCX Using CLI, on page 23.
Enter the command utils system restart to restart the server.

Upgrade Unified CCX Using Web Interface

Step 1
Step 2

You can upgrade Unified CCX either from alocal DVD or from a FTP/SFTP server.

Procedure

Loginto Cisco Unified OS Administration using administrator username and password.
Choose Softwar e Upgrades > Install/Upgrade.
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Step 3
Step 4

Step 5
Step 6
Step 7
Step 8

Step 9

Upgrade Unified CCX Using CLI .

Choose source as either DVD/CD or Remaote Filesystem from the Sourcelist.

Enter the path of the upgrade filein the Directory field. For Remote Filesystem, enter aforward slash (/)
followed by the directory path.

If you chose Remote Filesystem, follow the instructions on the screen; otherwise, skip to Step 6.
Click Next to seethelist of upgrades that are available.
Choose the appropriate upgrade file, and click Next.

Enter relevant information in the Email Destination and SM TP server fields to use the Email Notification
feature.

Click Next to initiate the upgrade process.

Note After upgrading Unified CCX, the CAsthat are not approved by Cisco areremoved from the platform
trust store. However, you can add them back, if necessary.

« For information about the list of CAsthat Cisco supports, see Cisco Trusted External Root
Bundle in https.//www.cisco.com/security/pki.

» For information about adding a certificate, follow the procedure mentioned from step 5 under
Obtain and Upload CA Certificate section in Cisco Unified Contact Center Express Admin
and Operations Guide.

Upgrade Unified CCX Using CLI

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Step 7

Procedure

Loginto Cisco Unified OS Platform CLI using administrator username and password.

Enter the command show version active and check the current version.

Enter the command utils system upgrade status and check that the node is ready for upgrade.
Enter the command utils system upgrade initiate to initiate the upgrade process.

Choose the source where the upgrade file is placed.

Follow the instructions on the screen.

Your entries are validated and the available files list is displayed.

After theinstallation is complete, enter the show ver sion inactive command to check the upgraded version.
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Note If you enter show ver sion active command during the upgrade process (by using an 1SO image),
it displaysthe version that is being upgraded to.

After upgrading Unified CCX, the CAsthat are not approved by Cisco areremoved from the platform
trust store. However, you can add them back, if necessary.

* For information about the list of CAsthat Cisco supports, see Cisco Trusted External Root
Bundle in https://www.cisco.com/security/pki.

» For information about adding a certificate, follow the procedure mentioned from step 5 under
Obtain and Upload CA Certificate section in Cisco Unified Contact Center Express Admin
and Operations Guide.

Upgrade VMware Tools

Perform the below proceduresto install and upgrade VMware tools for Unified CCX post Refresh Upgrade
and prior to initiating Switch Version.

Upgrade VMware Tools using vSphere Client for Unified CCX

Procedure
Step 1 Ensure you have powered on the virtual machine.
Step 2 Right-click the VM menu bar, choose Guest > I nstall/Upgrade VMwar e tools.
Step 3 Select the automatic tools update and click OK . It takes few minutesto complete. Once the update is complete,

the tools are listed as Running (Current) on the VM's Summary tab in vSphere.

Note For moreinformation about VMware ESXi'sthat are supported, refer to the Virtualization for Cisco
Unified Contact Center Express.

Upgrade VMware Tools using CLI for Unified CCX

Procedure

Step 1 Ensure you have powered on the virtual machine.

Step 2 Right-click the VM menu bar, choose Guest > I nstall/Upgrade VMwaretools.
Step 3 Select the interactive tools update and click OK.

Step 4 Open the console and login at the command prompt.

Step 5 Enter the command utils vmtools refresh and confirm.
The server automatically reboots twice.
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Step 6

Upgrade VMware Tools using Windows guest 0S for Unified CCX .

After reboot, check the Summary tab for the VM to verify that the VMware tools version is current. If it is
not current, reboot the VM and check the version again. It takes few minutes to complete. Once the process
is complete, the tools are listed as Running (Current) on the VM's Summary tab in vSphere.

Upgrade VMware Tools using Windows guest 0S for Unified CCX

Step 1
Step 2

Step 3
Step 4
Step 5

Step 6

Procedure

Ensure you have powered on the virtual machine.

Right-click the VM menu bar, choose Guest > I nstall/Upgrade VMwar e tools. Click OK on the popup
window.

Loginto the VM as a user with Administrative privileges.
Run VMware tools from the DVD drive. The installation wizard starts.

Follow the promptsin the wizard to complete the VMware Tool s install ation. Choose the Typical installation
option.

When the VM Tools installation finishes, restart the virtual machine for the changes to take effect. After the
processis complete, thetools are listed as Running (Current) on the VM's Summary tab in vSphere.

Change NIC Adapter Type

Step 1

Step 2
Step 3

Step 4

Step 5

Perform the below procedure post Refresh Upgrade and prior to initiating Switch Version.

Procedure

From VMwareV Sphere, select thevirtual machine > Edit Settings. The Virtual Machine Properties window
appears.
To add the new Network Adapter, on the Har dwar e tab, click Add. The Add Har dwar e window appears.

Select Device Type and Ethernet Adapter. Click Next. Choose the adapter type as VXMNET 3. Click Next
and Finish.

To remove the existing Network Adapter 1, under the Har dwar e tab, select Network Adapter 1, click
Remove, and select OK.

Power on the virtual machine.
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. Check and Perform Switch Version

Check and Perform Switch Version

A

Caution

\)

Never initiate switch version from therecovery CD.

Note

Step 1

Step 2

Step 3

* Perform switch version in the same maintenance window to avoid additional downtime.
« The time taken for switch version depends on the size of records in the database.

 Always ensure that all the third-party Wallboard server and WFM servers that query the Unified CCX
database externally are powered off prior to the switch version process. These servers may cause conflict
in database operations.

« Update the Unified CCX VM to latest OVA for 100 and 400 Agent profile for the switch version to be
successful. Thisis mandatory as the VRAM required has been changed. For more information, see the
Unified CCX Virtualization related information located at: https://www.cisco.com/c/dam/en/us/td/docs/
voice_ip_comm/uc_system/virtualization/virtualizati on-cisco-unified-contact-center-express.html.

« Do not modify the Hostname or I P address of the Unified CCX server before performing switch version.

Procedure

To check and perform switch version using the web interface:

a) Loginto Cisco Unified OS Administration using administrator username and password.
b) Choose Settings > Version to check the versions.

c) Click Switch Versions, and click OK to initiate the switch version process.

d) Choose Settings > Version to check the active version.

To check and perform switch version using the CLI:

a) Loginto Cisco Unified OS Platform CLI using administrator username and password.
b) Enter the command show version active to check the active version.

¢) Enter the command show version inactive to check the inactive version.

d) Enter the command utils system switch-version to initiate the switch version process.
€) Enter the command show version active to check the active version.

If switch version is unsuccessful:

a) Loginto Cisco Unified OS Platform CLI using administrator username and password.
b) Enter the command utils uccx switch-version db-check to check if the database is corrupt.
¢) Enter the command utils uccx switch-version db-recover to restore the database.

. Cisco Unified Contact Center Express Install and Upgrade Guide, Release 12.5(1) SU1


https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/virtualization-cisco-unified-contact-center-express.html
https://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/virtualization-cisco-unified-contact-center-express.html

Unified CCX Upgrade
| P

Verify Version of Unified CCX .

Verify Version of Unified CCX

)

You can verify the current active and inactive versions of Unified CCX either by using the web interface or
using CLI.

Note

Step 1

Step 2

For an HA setup, verify the versions on both the nodes.

Procedure

To verify the active and inactive versions of Unified CCX using the web interface:

a) Loginto Cisco Unified OS Administration using administrator username and password.
b) Choose Settings > Version to check the current active and inactive versions.

To verify the active and inactive versions of Unified CCX using the CLI:

a) Loginto Cisco Unified OS Platform CLI using administrator username and password.
b) Enter the command show version active to check the active version.

¢) Enter the command show version inactive to check the inactive version.

Verify Status of Services

\)

Note

Step 1

Step 2

Step 3

For HA setup, verify the services on both the nodes.

Procedure

To verify the status of Customer Collaboration Platform:

a) After Unified CCX upgrade, loginto Cisco Unified CCX Administration using administrator username
and password.

b) Choose Subsystems> Chat and Email CCP Configuration.

c) Click Save and verify that the CCP Status displays green for all the components.

To verify the status of services using the web interface:

a) Loginto Cisco Unified CCX Serviceability using administrator username and password.

b) Choose Tools > Control Center - Network Services and verify that all the services are running.

To verify the status of services using the CLI:
a) Loginto Cisco Unified OS Platform CLI using administrator username and password.
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. Verify Unified CCX Database Replication

b) Enter the command utils servicelist to verify that al the services are running.

Verify Unified CCX Database Replication

N\

Note

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

For Cisco Finesse Desktop Failover to succeed, ensure the status of Cisco Database Replication is'Good
replication'.

Procedure

Loginto Cisco Unified CCX Serviceability using administrator username and password.

Choose Tools > Datastore Control Center > Replication Servers.

Ensure the serversarein ACTIVE/CONNECTED state and database replication of the operating system is
functioning between the first node and the second node.

If there is a problem with the replication continue; otherwise, skip to Step 5.

a) Loginto Unified CCX CLI using Unified CCX username and password.

b) Enter the command utils uccx dbreplication status and determine the location and cause of failure.

¢) Enter thecommand utilsuccx dbreplication repair {all|database name} on the node or nodesto remove
data discrepancy between the nodes.

d) Enter the command utils uccx dbreplication status to ensure the status is 'Good replication'. If failure
persists, continue; otherwise, skip to Step 5.

€) Enter the command utils uccx dbreplication tear down to remove database replication.

f) Enter the command utils uccx dbreplication setup to setup database replication.

g) Enter the command utils uccx dbreplication status to ensure the status is 'Good replication'.

Loginto Unified CCX Administration using Unified CCX username and password.
Verify that your configuration data exists on both the nodes.

Verify Cisco Database Replication

Step 1
Step 2
Step 3
Step 4
Step 5

Procedure

Run the Cisco Unified Real-Time Monitoring Tool (RTMT).

Choose System > Perfor mance > Open Perfor mance M onitoring.

Click the Nodel or Node2 radio button as required.

Click the Number of Replicates Created and State of Replication radio button.
Double-click Replicate State.
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Step 6 Choose ReplicateCount, and click Add.
The “Performance Counter” graph is displayed in the right window.

Step 7 Use the following list to monitor the status of database replication.

* O—lInitiaizing

» 1—Replication setup script fired from this node

» 2—Good replication

* 3—Bad replication

» 4—Replication setup did not succeed

Step 8 If there is a problem with the replication:
a) Loginto Cisco Unified OS Platform CLI using administrator username and password.
b) Enter the command utils dbreplication status{all|nodejreplicate} and determine the location and cause
of failure.
c) Enter the command utils dbreplication repair{nodenamelall} on the node or nodes to remove data
discrepancy between the nodes.

d) Enter the command utils dbreplication statusto ensure the statusis 'Good replication'.

Upgrade Unified CCX Editor

Procedure

Step 1 Uninstall the Unified CCX Editor.

Step 2 Loginto Cisco Unified CCX Administration using Unified CCX username and password.
Step 3 Choose Tools > Plug-ins.

Step 4 Click the Cisco Unified CCX Editor Web Launcher hyperlink.

Step 5 Download the Unified CCX Editor (.jnip) file.

Launch Unified CCX Editor

Procedure

Step 1 Loginto Cisco Unified CCX Administration using Unified CCX username and password.
Step 2 Choose Tools > Plug-ins.
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. Install Unified CCX Real-Time Monitoring Tool

Step 3 Click the Cisco Unified CCX Editor Web Launcher hyperlink to download and launch the Unified CCX
Editor (.jnlp) file.

Install Unified CCX Real-Time Monitoring Tool

Procedure

Step 1 Uninstall the previous version of Unified CCX Real-Time Monitoring Tool.

Step 2 Log into Cisco Unified CCX Administration using Unified CCX username and password.

Step 3 Choose Tools > Plug-ins.

Step 4 Click Cisco Unified Real-Time Monitoring Tool for Windows or Cisco Unified Real-Time M onitoring
Tool for Linux to download and install Unified Real-time Monitoring Tool.

Note * Thecurrent Unified RTMT requires JRE to run. Verify that the system has JRE installed (Java
1.8).

* On aLinux workstation, run RTMT with root access. Otherwise, when you initialy install
RTMT, the application will not start.

Launch Unified CCX Real-Time Reporting Tool

Procedure

Step 1 Log into Cisco Unified CCX Administration using Unified CCX username and password.
Step 2 Choose Tools > Plug-ins.

Step 3 Click the Cisco Unified CCX Real-Time Reporting Tool hyperlink to download and launch the RTR (.jnIp)
file.
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CHAPTER 5

Unified CCX Rollback

 Important Considerations for Rollback, on page 31

* Roll Back Upgrade for Single Node Setup, on page 31

* Roll Back Upgrade for HA Setup, on page 32

* Reset Database Replication after Rollback, on page 32

« Roll Back Unified CCX Clients, on page 32

* Impact on Historical Reporting Users After Roll Back, on page 33

Important Considerations for Rollback

A

Caution

Configuration/reporting updates that are made after the upgrade are not be preserved when you roll back.

« Do not make any configuration changes during the rollback, because the changes are lost after the rollback.

* In an HA setup, do not switch versions on both the first and second nodes at the same time. Perform
switch version on the second node only after you have switched versions on the first node.

Roll Back Upgrade for Single Node Setup

Step 1
Step 2
Step 3
Step 4

Procedure

Check and Perform Switch Version
Verify Version of Unified CCX, on page 27
Verify Status of Services

Roll Back Unified CCX Clients, on page 32

Related Topics
Check and Perform Switch Version, on page 26
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. Roll Back Upgrade for HA Setup

Roll Back Upgrade for HA Setup

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8

Procedure

Check and Perform Switch Version. Perform switch version on the first node.
Check and Perform Switch Version. Perform switch version on the second node.
Verify Version of Unified CCX, on page 27

Verify Status of Services

Roll Back Unified CCX Clients, on page 32

Reset Database Replication after Rollback, on page 32

Verify Unified CCX Database Replication, on page 28

Verify Cisco Database Replication, on page 28

Related Topics
Check and Perform Switch Version, on page 26

Reset Database Replication after Rollback

Step 1
Step 2

If you roll back to an older version of Unified CCX, you must manually reset database replication within the
cluster for an HA setup.

Procedure

Loginto Cisco Unified OS Platform CLI using administrator username and password.
Enter the command utils uccx dbreplication reset all to reset database replication.

Roll Back Unified CCX Clients

Step 1

Step 2
Step 3
Step 4
Step 5

Procedure

Remove the Editor. For moreinformation, refer to the "Removal of the Unified CCX Editor" section in Cisco
Unified Contact Center Express Getting Started with Scripts Guide .

Uninstall the Cisco Unified Real-Time Monitoring Tool.

Remove the Cisco Unified Real-Time Reporting Tool.

Loginto Cisco Unified CCX Administration using Unified CCX username and password.
Choose Tools > Plug-ins.
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Step 6

Step 7

Step 8

Impact on Historical Reporting Users After Roll Back .

Click the Cisco Unified CCX Editor Web Launcher hyperlink to download and launch the Unified CCX
Editor (.jnlp) file. No installation required.

Before launching the downloaded INL Pfile, copy thefileto adifferent location for future use. Ensureto clear
the Java cache before launching the INLP file.

Click Cisco Unified Real-Time Monitoring Tool for Windows or Cisco Unified Real-Time Monitoring
Tool for Linux asrequired to install Unified RTMT.

Click Cisco Unified Real-Time Reporting Tool to launch Unified Real-Time Reporting Tool.

Impact on Historical Reporting Users After Roll Back

Step 1
Step 2
Step 3
Step 4

Rolling back versions from alater version of Unified CCX to an earlier version does not retain the privileges
of Historical Report Users that were created in later version. These users will not have access to Historical
Reports. After reverting to the earlier version, update the reporting capability for them.

To update the reporting capability:

Procedure
Loginto Cisco Unified CCX Administration using Unified CCX username and password.
Choose Tools > User Management > Reporting Capability.

Select the users that you want to update.
Click Update.
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. Cisco Unified Contact Center Express Install and Upgrade Guide, Release 12.5(1) SU1



APPENDIX A

Server Configuration Table

« Server Configuration Information for Installation, on page 35

Server Configuration Information for Installation
~

Note * You can use the configuration table for saving your entries either on a printed paper or in the PDF
document.

» Be aware that the field values (namely hostname and passwords) that you enter while you are running

the installation program are case-sensitive. Hostname must be in lower case and the character limit is 24
characters.

« All the fields may not be applicable to your system and network configuration. Unless mentioned
otherwise, you can change the values of most fields after the installation using CLI commands.

Attention  Changes to some of the configuration parameters may result in changes to the licence MAC, and you may

have to rehost the Unified CCX license. For information about the configuration parameters, see Unified
CCX Licenses.

Table 4: Node Configuration Table

Parameter Your Entry

Administrator |ID

Attention You cannot change the original administrator account
user ID; you can create additional administrator
accounts.

Caution Do not create administrator 1Ds (for CLI access or
Operating System administration) that start with
"ucex" or "UCCX" because such I Ds conflict with
system account namesthat are used internally within
the Unified CCX server.
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Parameter Your Entry

Administrator Password

Attention Thisfield specifiesthe password for the administrator
account, which you use for secure shell accessto the
CLlI, for logging in to Cisco Unified Operating
System Administration, and for logging in to the
Disaster Recovery System. Ensure that the password
isat least six characterslong; it can contain
alphanumeric characters, hyphens, and underscores.

You can change the password after installation.

Application User Name

Application User Password

Attention Use the Application User password as the default
password for applications that are installed on the
system, including Unified CCX and Unified
Communications Manager. Ensure that the password
isat least six characterslong; it can contain
alphanumeric characters, hyphens, and underscores.

You can change the password after installation.

DNS Primary

DNS Secondary (optional)

Domain

Gateway Address

Hosthame

IP Address

P Mask

MTU Size

Note Use the same Maximum Transmission Unit (MTU)
valuefor all serversin the cluster.

NIC Duplex

Note This parameter is not displayed if automatic
negotiation is used.

NIC Speed

Note This parameter is not displayed if automatic
negotiation is used.
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Parameter

Your Entry

NTP Server

Attention Enter the hostname or |P address of one or more

Network Time Protocol (NTP) servers with which
you want to synchronize.

You can enter up to five NTP servers.

You can change the NTP server after installation.

Security Password

Attention Serversin the cluster use the Security password to

communicate with one another. The password must
contain at least six alphanumeric characters. It can
contain hyphens and underscores, but it must start
with an aphanumeric character.

Save this password. You will be asked to enter the
same Security password when you install the second
node to form a cluster.

You can change the password after installation by
using the following CLI command:

CLI > set password user security

To avoid losing communi cations between nodes, you
must change the Security password on both nodesin
acluster and reboot both the nodes. For more
information, see the description of this command in
the Cisco Unified Operating System Administration
Guide at https://www.cisco.com/c/en/us/support/
customer-collaboration/
unified-contact-center-express/
products-maintenance-guides-list.html.

SMTP Location

Note You must populate thisfield if you plan to use
electronic notification.

Organization

Note The value you enter is used to generate a CSR.

Unit

Note The value you enter is used to generate a CSR.

L ocation

State

Note The value you enter is used to generate a CSR.
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Parameter

Your Entry

Country

Note The value you enter is used to generate a CSR and
self-signed certificates.

Time Zone

Related Topics
Add Second Node, on page 6
Install Unified CCX from Installation DVD, on page 5
Install Unified CCX on Second Node, on page 7
Unattended Installation, on page 7

Perform Unattended Installation Using Answer File Generator, on page 8
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APPENDIX B

Unified CCX Licenses

From Unified CCX release 12.5(1), fresh install of Unified CCX supports only Smart Licensing. For more
information on migrating to smart Licensing, see Cisco Unified Contact Center Express Features Guide. If
you are upgrading from releases prior to Unified CCX 12.5(1) and want to continue using Classic Licensing,
see the following sectionsin the document.

The Unified CCX licenses are based on a string called the license MAC, which is different from the physical
MAC address of a system. License MAC is dependent on the system parameters. A modification to any of
the parameters can change license MAC, thereby invalidating current License files. The following are the
parameters on which the validity of alicense MAC depends:

* Time zone

* NTP server 1 (or none)
* NIC speed (or auto)

* Hostname

* |IP Address

* IP Mask

» Gateway Address

* Primary DNS

* SMTP server

* Certificate Information (Organization, Unit, Location, State, Country)

Note

The Unified CCX Warm Standby license and all other licenses are node-locked to the License MAC address
of thefirst node (typically the Database Publisher node) of a Unified CCX cluster. When a second node is
added, the verification of avalid add-on Warm Standby license on thefirst nodeis performed. After the cluster
isset up, the licenses are valid on both the nodesin a cluster.

* Obtain License MAC, on page 40
* Upload Licenses, on page 40
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Obtain License MAC

License MAC can be obtained in two ways—Dby using either the Command Line I nterface or the Administrator
Web interface.

Obtaining License MAC using Command Line Interface

Step 1
Step 2

Step 3

Procedure

Log in to the Unified CCX system CLI using Unified CCX Administrator credentials.
Run show status command.

Output of this command contains the license MAC.

Use the license MAC to get the license from Cisco.

Contact the Support team for any license inquiries at:
www.cisco.com/en/US/partner/support/tsd_cisco_worldwide_contacts.html

Obtaining License MAC using Administrator Web Interface

Step 1

Step 2

Step 3
Step 4
Step 5

Procedure

Login to the Unified CCX Administrator web interface using Unified CCX Administrator credentials.

Note User IDs are case-sensitive when logging into the Unified CCX Administration web interface. To
make them case-insensitive, you must install 12.5(1) SU1 ESO2.

Click System > License Management.
In the License Management page, by default Classic Licensing is selected.

Click Next.
Obtain the license MAC from the View Licenses section.
Use the license MAC to obtain license from Cisco.

Upload Licenses

Softwarefor al of the Unified CCX feature components areloaded on the system during installation. However,
no feature is available for use unless alicense for that feature is added and activated.

You can upload and display licenses using the License Information page. To upload alicense, complete the
following steps.
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Step 1

Step 2

Step 3

Unified CCX Licenses [

Procedure

From the Unified CCX Administration menu bar, choose System > License I nformation > Add License(s).

The License Information web page opens.

Specify a Licensefile or click Browseto locate afile.
You can either specify asinglefile with a.lic extension or a.zip file containing multiple .lic files.

Note While you are upgrading from a previous release, if there are multiple licenses, zip all the .lic files
into asingle .zip file and then upload the zip file. If specifying a .zip file, ensure that all .lic files
that need to be added are in the root of the .zip file and are not in subfoldersin the .zip file.

Click Upload.

On successful upload of the license, you will see the following confirmation message in the status bar at the
top of thisweb page: Li cense has been upl oaded successfully

If you upload an Add-on license to increase the existing licensed Outbound 1V R ports, the following message
will be displayed :

As the nunber of |icensed Qutbound IVR Ports have increased, please
i ncrease the nunmber of ports in the Qutbound Call Control Goup to utilize
all the licensed ports.

Cisco Unified Contact Center Express Install and Upgrade Guide, Release 12.5(1) SU1 .



Unified CCX Licenses |
[l unified cCX Licenses

. Cisco Unified Contact Center Express Install and Upgrade Guide, Release 12.5(1) SU1



A

Apply patch 8
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license 40
adding components 40

uploading licenses 40
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