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C H A P T E R  1
Introduction

This section provides an introduction to Cisco UC Integration for Microsoft Lync.

• Cisco UC Integration for Microsoft Lync, page 1

Cisco UC Integration for Microsoft Lync
Cisco UC Integration for Microsoft Lync is a Microsoft Windows desktop application that provides access
to Cisco Unified Communications from Microsoft Lync. The solution extends the presence and instant
messaging capabilities of Microsoft Lync by providing access to a broad set of Cisco Unified Communications
capabilities; including software phone standards-based video, unified messaging, conferencing, desktop phone
control and phone presence.

Key features of Cisco UC Integration for Microsoft Lync include:

• Make and receive video calls using the Cisco Precision Video engine.

• Make and receive phone calls through Cisco Unified Communications Manager.

• Drag and drop and right-click integration with the Microsoft Lync contact list.

• Instant Messaging and Presence integration with Microsoft Lync.

• Mute, hold, and transfer during calls.

• Software phone or desktop phone mode selection.

• Communications history of missed, placed, and received calls.

• Audio and visual notification of incoming calls.

• Ad hoc conferencing.

• Visual voicemail.

• Click to Call from the Microsoft Outlook and Excel Ribbon and Internet Explorer.

• Start a CiscoWebExmeeting from the contact list, a conversation, or aMicrosoft Lync instant messaging
session.

◦Right-click a Microsoft Lync contact and select Instant WebEx meeting.
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◦Select multiple contacts in the Microsoft Lync Contact List, right-click, and select Instant Webex
meeting.

◦Meetings can also be started from Call History, Voicemail, and search results. Right-click an entry
and select Instant WebEx meeting.

• Expressway Mobile and Remote Access

• Service Discovery
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C H A P T E R  2
User Interface Overview

This section provides an overview of the Cisco UC Integration for Microsoft Lync user interface.

• Docked Window, page 3

• Incoming Call Window, page 4

• Call Window, page 4

• Hub Window, page 6

• Options Window, page 7

Docked Window
Cisco UC Integration for Microsoft Lync now includes a user interface option that displays a small window
at the top of the screen and allows users to quickly access common functions.

Select View > Show docked window to show or hide the docked window.

Select View > Position docked window to position the docked window and then select one of the following:

• Top left

• Top center

• Top right

The docked window provides access to the following functions:

• Contact search

• Direct dialing of phone numbers

• Call history

• Voicemail

• Hub display
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Users must not position the Microsoft Windows taskbar on the top of the screen. The docked window
displays only at the top of the screen. If users position the Windows taskbar at the top of the screen, the
taskbar might overlay the docked window. If the taskbar overlays the docked window, the users cannot
access the docked window.

Restriction

Incoming Call Window
The Incoming Call window displays when you receive an incoming call. This window provides options for:

• Accepting a call
Select Accept to connect the call and begin a conversation. The Call window is displayed after the call
is connected. See Call Window, on page 4 for more information.

• Declining a call
Select Decline to not answer the call. Declined calls are sent to voicemail if it is configured. See
Voicemail, on page 14 for more information.

Call Window
The Call window is displayed during every connected call. This window provides options for control of the
call and displays video during video calls. See Options Window, on page 7 for information on how to
control how video is displayed when a call is connected.
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The Call window provides the following call controls:

• Start my video
Starts sending video in calls where video is not automatically sent.

• Full screen
Expands video display to a full screen view.

• Toggle self-view
Opens a small video display that shows the video you are sending.

• Keypad
Opens a keypad to enter digits.

•Mute

• Mutes the audio.

• Hold
Places the current call on hold.

• Transfer
Provides options to transfer the call to a different number.

•Merge

Provides options to merge the current call with another.

• Conference Call
Provides options for creating a conference call.

• Start Meeting

Starts a Cisco WebEx meeting with the call participant.
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Hub Window
The Hub window displays call history, voicemails, and meetings. Phone configuration is also performed on
this window. The Hub window is displayed when the user first logs into the application but can be hidden by
closing it. Use the Docked window when the Hub window is closed to access the Hub window functions. See
Docked Window, on page 3 for more information.
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Options Window
TheOptions window is used to configure CiscoUC Integration forMicrosoft Lync according to user preferences
and deployment. Access the window by selecting File > Options on the Hub window. Select Apply or OK
after making changes on this window to save those changes. Select Cancel to cancel any changes.

The following table lists the settings that can be configured on this window.

DescriptionSettingCategory

Starts the application automatically
when the computer is started if
selected.

Start Cisco UC for Lync when
my computer starts.

General
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DescriptionSettingCategory

Automatically sends video when a
calls starts if selected. This is the
default selection.

Always start calls with video.Calls

Never sends video when a call
starts if selected. Video can be
started manually during the call.

Never start calls with video.

Call the contact's default number
when initiating a call from
Microsoft Lync.

Call the default number

Allow the user to select a number
to call when initiating a call from
Microsoft Lync.

Allowme to select the number to
call

Display the Call Information
Window when a call is answered.
See Call Information Windows,
on page 15 for more information.

Display information when call is
answered

Select the speaker the application
will use from the drop down list.
Use the slider under the drop down
list to adjust the volume.

SpeakerAudio

Select the microphone the
application will use from the drop
down list. Use the slider under the
drop down list to adjust the
volume. The strength indicator
under the drop down list indicates
the current loudness of the
microphone.

Microphone

Select the device the application
will use to play ringer and alert
sounds from the drop down list.
Use the slider under the drop down
list to adjust the volume.

Ringer/Alerts

SelectAdvanced >> to arrange the
order of preference for each audio
device.

Advanced >>
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DescriptionSettingCategory

Select the camera the application
will use from the drop down list.
A video preview will be displayed
if the camera is selected
successfully.

CameraVideo

SelectAdvanced >> to arrange the
order of preference for each camera
device.

Advanced >>

Enter the user name and password
associated with your Cisco Unity
Connection voicemail account.
Consult your system administrator
if you do not have this information.
Select Advanced >> if you need
to input Cisco Unity Connection
server information. This
information will be supplied by
your system administrator if
necessary.

VoicemailPhone accounts

Select Edit Account to enter the
address of your Cisco WebEx
server.

Edit AccountMeetings

Select this checkbox to receive
pop-up meeting reminders.

Meeting Reminders

Use the link provided to edit your
One-Click Meeting settings.

One-Click Meeting

Select the calendar to integrate with
the application.

Calendar integrationIntegration
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C H A P T E R  3
Features and Functionality

This section contains information and procedures on the features and functionality of Cisco UC Integration
for Microsoft Lync.

• Contact Search, page 11

• Call History, page 12

• Direct Dial, page 12

• Drag and Drop Contacts, page 12

• Call a Contact from Microsoft Lync, page 13

• Receive a Call, page 13

• Voicemail, page 14

• Click to Call Functionality, page 14

• Set the Preferred Phone Device, page 15

• Call Information Windows, page 15

• Initiate a Chat Session, page 16

• Add Meeting Accounts, page 16

• Start a Cisco WebEx Meeting, page 16

Contact Search
Perform the following procedure to place a call using the contact search.
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Procedure

Step 1 Select the dockable window.
Step 2 Begin typing the name of the contact in the search box.
Step 3 Select the desired contact from the search results.
Step 4 Use the call icon beside the contact name to place a call.

Call History
Perform the following procedure to place a call using the call history.

Procedure

Step 1 Select the dockable window.
Step 2 Select the Calls icon.

The Hub window opens.

Step 3 Select the desired phone number from the list.
Step 4 Use the call icon beside the phone number to place a call.
Step 5 Close the Hub window.

Direct Dial
Perform the following procedure to place a call using direct dialing.

Procedure

Step 1 Select the dockable window.
Step 2 Enter the phone number in the search box.
Step 3 Press Enter.

Drag and Drop Contacts
Perform the following procedure to place a call by dragging and dropping Microsoft Lync contacts.

   Cisco UC Integration for Microsoft Lync 9.7(4) User Guide
12

Features and Functionality
Call History



Procedure

Step 1 Select Microsoft Lync.
Step 2 Select and drag the desired contact to the dockable window.
Step 3 Drop the contact on the dockable window.

A call will be placed to the contact.

Call a Contact from Microsoft Lync
Perform the following procedure to call a contact from within Microsoft Lync.

Procedure

Step 1 Select Microsoft Lync.
Step 2 Perform one of the following actions to place a call:

a) Right-click a contact and select Place Call.
b) Select Show Participant List from aMicrosoft Lync instant messaging window. Right-click a participant

and select Place Call.
c) Select several participants in a Microsoft Lync group chat and right click to make a conference call. This

feature is only available with Microsoft Lync 2010.
d) Right-click a contact and display their Microsoft Lync Contact Card. Select View more options for

interacting with this person. Use the presented option for making a call. This feature is only available
with Microsoft Lync 2010.

Receive a Call
The Incoming Call window displays when you receive an incoming call. This window provides options for:

• Accepting a call
Select Accept to connect the call and begin a conversation. The Call window is displayed after the call
is connected. See Call Window, on page 4 for more information.

• Declining a call
Select Decline to not answer the call. Declined calls are sent to voicemail if it is configured. See
Voicemail, on page 14 for more information.

Cisco UC Integration for Microsoft Lync 9.7(4) User Guide    
13

Features and Functionality
Call a Contact from Microsoft Lync



Voicemail
The Voicemail tab on the Hub window provides access to your voicemail. This tab displays a list of all current
voicemail messages.

Cisco UC Integration with Microsoft Lync provides access to your corporate voicemail. Select the Voicemail
tab on the main window. This tab displays a list of all current voicemail messages. You can interact with the
messages on this tab by:

• Selecting a message to play it.

• Selecting anywhere in the playback bar to reverse or advance playback.

• Pausing playback by selecting the Pause button.

Voicemail messages are deleted by selecting a message, right-clicking it, and selecting Delete.

The text of unplayed messages are bolded to distinguish them from played messages.

Click to Call Functionality
Cisco UC Integration for Microsoft Lync integrates with Microsoft Outlook, Microsoft Excel, and Microsoft
Internet Explorer to provide Click to Call functionality in those applications. Click to Call provides the ability
to call phone numbers or contacts without leaving the application. The following features are provided:

•Microsoft Outlook

◦Call the sender of the currently highlighted message in the main Outlook window using the button
provided on the Ribbon (Microsoft Outlook 2010 only).

◦Select a recipient of the currently highlighted message to call in the main Outlook window using
the button provided on the Ribbon (Microsoft Outlook 2010 only).

◦Call the sender of the currently read email from the Ribbon in the message window.

◦Select a recipient of the currently read email to call from the Ribbon in the message window.

◦Call the selected contact or recipients list directly or using the Call With Edit option with the
Ribbon button.

◦Right-click the sender or any recipient to call them using theAdditional Actions right-click menu
item. Senders or recipients can be called directly or using the Call With Edit option. This is a
Smart Tag option only available in Microsoft Outlook 2003 or 2007.

◦Right-click any user and call them. Use the Contacts > Additional Actions menu in Microsoft
Office 2007. Contacts are accessed directly in Microsoft Office 2010. Contacts can be called
directly or using the Call With Edit option.

◦Call a contact from the Contact window using the buttons provided on the Ribbon.

◦Call a contact from any Calendar item using the buttons provided on the Ribbon.

•Microsoft Excel

◦Call a phone number highlighted in a spreadsheet using the button provided on the Ribbon.
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◦Right-click and call a phone number highlighted in a spreadsheet.

◦Use theCall with Edit button in the Ribbon to modify a selected value or enter a different number.

◦Use the Call with Edit item in the right-click menu to modify a selected value or enter a different
number.

•Microsoft Internet Explorer

◦Right-click and call a phone number highlighted on a web page.

◦Use the Call with Edit item in the right-click menu to modify a selected value or enter a different
number.

See Software Requirements in the Cisco UC Integration for Microsoft Lync Release Notes for information on
the supported versions of each application.

Set the Preferred Phone Device
Perform the following procedure to set the preferred phone device.

Procedure

Step 1 Select the dockable window.
Step 2 Select the Hub window icon.
Step 3 Select the phone device selection drop down list in the bottom right hand corner of the Hub window.

This list is populated with all of your configured phone devices. If a device is not available and should
be, contact your system administrator.

Note

Step 4 Select your preferred phone device.

Call Information Windows
Cisco UC Integration for Microsoft Lync has the ability to display contact and other information about
connected incoming calls. These information windows are displayed after the call is connected in either a new
Microsoft Internet Explorer tab or window. A new information window is displayed when the following
occurs:

• An incoming call is connected.

• A call is transferred to you from another user.

• Participants are added to a conference call. An informationwindow is displayed for each unique participant
in a conference call.

These information windows are configured by your administrator. They will inform you if this functionality
is available to you.
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You can control the appearance of call information windows. Select File >Options from the menu and select
the Calls tab. Select or deselect Display information when call is answered according to your preference.

Initiate a Chat Session
Perform the following procedure to initiate a Microsoft Lync chat session from Cisco UC Integration for
Microsoft Lync.

Procedure

Step 1 Right-click a contact in Cisco UC Integration for Microsoft Lync in either search results, the Call History tab,
or the Voicemail tab.

Step 2 Select Chat.
This feature is only available with Microsoft Lync
2010.

Note

This feature will not work if Microsoft Lync is not running or the user is not signed
in.

Note

Add Meeting Accounts
Add a Cisco WebEx account to quickly start, join, and manage online conferences.

Procedure

Step 1 Select File > Options.
Step 2 Select theMeetings tab.
Step 3 Select Edit account.
Step 4 Select New Site from theWebEx Site drop-down list.
Step 5 Enter the site and associated user name and password in the fields provided.
Step 6 Select OK.

Start a Cisco WebEx Meeting
Start a Cisco WebEx meeting with one of the following actions:

• Right-click a Microsoft Lync contact and select Instant WebEx meeting.

• Select multiple contacts in the Microsoft Lync Contact List, right-click, and select Instant Webex
meeting.
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• Meetings can also be started from Call History, Voicemail, and search results. Right-click an entry and
select Instant WebEx meeting.

This feature is only available if a user has set up a CiscoWebExMeeting account. See AddMeeting Accounts,
on page 16 for more information.
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