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Introduction
Welcome to Cisco UC Integration for Microsoft Lync. This application extends the presence and instant messaging capabilities of
Microsoft Lync by providing access to a broad set of Cisco Unified Communications capabilities. Here are some of the things you'll
be able to do:

• Make and receive voice and video calls through Cisco Unified Communications Manager.

• Drag and drop and right-click directly from Microsoft Lync to make a call.

• Instant Messaging and Presence integration with Microsoft Lync.

• Mute, hold, and transfer during calls.

• Software phone or desktop phone mode selection.

• Communications history of missed, placed, and received calls.

• Audio and visual notification of incoming calls.

• Ad hoc conferencing.

• Visual voicemail.

• Click to Call from Internet Explorer, Microsoft Outlook and other Microsoft Office applications.

• Start a Cisco WebEx meeting.

• Service Discovery.

Calls

Call From Docked Window

Procedure

Step 1 Select the dockable window.
Step 2 Begin typing the name of the contact in the search box.
Step 3 Select the desired contact from the search results.
Step 4 Use the call icon beside the phone number to place a call.
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Call From Call History

Procedure

Step 1 Select the dockable window.
Step 2 Select the Recents icon.

The hub window opens.
Step 3 Select the desired phone number from the list.
Step 4 Use the call icon beside the phone number to place a call.

Drag and Drop Contacts
You can drag and drop your Microsoft Lync contacts to initiate a call.

Procedure

Step 1 Select your contact in Microsoft Lync.
Step 2 Drag and drop the contact to the dockable window.

A call is placed to the contact.

Start Calls with Video

Procedure

Step 1 In the hub window, select File > Options
Step 2 Select the Calls tab.
Step 3 Select Always start calls with video.
Step 4 Select Apply.

Start Calls with Default Number
Use the contacts default number when you initiate a call from Microsoft Lync.
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Procedure

Step 1 In the hub window, select File > Options
Step 2 Select the Calls tab.
Step 3 Select Call the default number.
Step 4 Select Apply

Select your Preferred Phone Device

Procedure

Step 1 In the hub window, open the Phone Controls drop-down menu.
Step 2 Select your preferred phone device.

Show the Call Information Windows
You can view contact and other information about connected incoming calls. These information windows are displayed after the call
is connected in either a new Microsoft Internet Explorer tab or window.

Procedure

Step 1 In the hub window, select File > Options
Step 2 Select the Calls tab.
Step 3 Select Display information when call is answered.
Step 4 Select Apply.

Check Your Voice Messages

Procedure

Step 1 Select the voice messages tab on the hub window.
Step 2 You can listen to your voice messages by selecting a message to play.

You can delete your message by right-clicking it and selecting Delete.
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Click to Call

Call from Microsoft Outlook

Procedure

Step 1 Select an email in your inbox.
Step 2 You can create a call using one of the following options:

• In the ribbon menu, select Call_sender_name

• In the ribbon menu select the Recipients drop-down list. Choose the recipient you wish to call.

Call from Microsoft Office Applications

Procedure

Step 1 Highlight a number in the current document.
Step 2 Start a call using one of the following options:

• On the ribbon menu select one of the following:

◦Call

◦Call with edit—You can edit the number before creating the call.

• In Microsoft Word or Microsoft Excel you can right-click and select one of the following menu options:

◦Call

◦Call with edit—You can edit the number before creating the call.

Call from Internet Explorer

Procedure

Step 1 Highlight a number on a web page in Internet Explorer.
Step 2 Right-click and select one of the following:
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• Call

• Call with Edit..—You can edit the number before creating the call.

Start a Chat
You can start a Microsoft Lync chat session from Cisco UC Integration for Microsoft Lync.

Before You Begin

This feature is only available with Microsoft Lync 2010 or Microsoft Lync 2013.

This feature is not available if Microsoft Lync is not running or the user is not logged in.

Procedure

Step 1 Right-click a contact in Cisco UC Integration for Microsoft Lync in either search results, the call history tab, or voicemail
tab.

Step 2 Select Chat.

Create a WebEx Meeting

Procedure

Step 1 Select a contact or multiple contacts from one of the following:

• Microsoft Lync contacts list

• Recents list

• Voicemail

• Search results

Step 2 Right-click and select Instant WebEx Meeting.
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Customize

Select Audio Devices

Procedure

Step 1 In the hub window, select File > Options
The options window opens.

Step 2 Select the Audio tab.
Step 3 Choose your Speaker, Microphone, and Ringer/Alerts options.
Step 4 Select Apply.

Arrange Audio Devices
If you have more than one audio device, you can arrange them in order of preference.

Procedure

Step 1 In the hub window, select File > Options
Step 2 Select Advanced.
Step 3 Select your audio device and use the up and down arrow to set the order.

Select Video Devices

Procedure

Step 1 In the hub window, select File > Options
The options window opens.

Step 2 Select the Video tab.
Step 3 Choose your camera.
Step 4 Select Apply.

Arrange Video Devices
If you have more than one video device, you can arrange them in order of preference.
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Procedure

Step 1 Select File > Options
Step 2 Select the Video tab and then Advanced.
Step 3 Select your camera and use the up and down arrows to set the order.

Add Phone Account

Procedure

Step 1 Select File > Options
Step 2 Select Phone accounts.
Step 3 (Optional) Select Advanced to input the Cisco Unity Connection server information.
Step 4 Enter the username and password for your Cisco Unity Connection account.

Add Meetings Accounts

Procedure

Step 1 Select File > Options.
Step 2 Select theMeetings tab.
Step 3 Select Edit account.
Step 4 Select New Site from theWebEx Site drop-down list.
Step 5 Enter the site and associate username and password in the fields provided.
Step 6 Select Ok.

Integrate Your Calendar

Procedure

Step 1 Select File > Options.
Step 2 Select the Integration tab.
Step 3 Select the calendar to integrate with the application.
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Accessibility

Keyboard Shortcuts

Global Shortcuts

Keyboard ShortcutOperation

CTRL + Shift + ?Access the docked window

To show the docked window:Tip

1 Open the Hub window.

2 Select View > Show docked
window.

Menu key

Shift + F10

Open the context menu

Incoming Calls

Keyboard ShortcutOperation

CTRL + LAnswer calls

CTRL + DDecline calls

CTRL + RReply to calls with chat

Active Calls

Keyboard ShortcutOperation

CTRL + KEnd calls

CTRL + SHIFT + FEnter or exit full screen mode

CTRL + SHIFT + BShow or hide self-view video

CTRL + Down ArrowMute or unmute your audio

CTRL + SHIFT + VStart or stop video
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Keyboard ShortcutOperation

CTRL + ALT + PDock or undock the call window

CTRL + SHIFT + HHold or resume calls

CTRL + SHIFT + K

Enter numbers on the keypad with your
keyboard.

Tip

Open or close the keypad

CTRL + SHIFT + Up ArrowIncrease Volume

CTRL + SHIFT + Down ArrowDecrease Volume

CTRL + SHIFT + PlusOpen or close the More menu

CTRL + MOpen the Merge menu when calls are on hold

CTRL + SHIFT + TTransfer a call

CTRL + SHIFT + CStart a conference call

CTRL + SHIFT + SShow call statistics

Font Smoothing
Administrators who install and configure Cisco UC Integration for Microsoft Lync can control how font smoothing occurs.

The ForceFontSmoothing parameter specifies whether the client or the operating system applies anti-aliasing to text. By default, the
client applies anti-aliasing to smooth text.

If you want the operating system to apply anti-aliasing to text, set the ForceFontSmoothing parameter in the client configuration as
follows:
<Policies>
<ForceFontSmoothing>false</ForceFontSmoothing>

</Policies>

Troubleshooting

Presence Behavior

Expected presence behavior in Microsoft Lync when Cisco UC Integration for Microsoft Lync is used for calls

Mouse move desk
phone or return from
idle

End a call using desk
phone, status changes
to:

End a call using soft
phone, status changes
to:

On a call using the
desk phone, status
changes to:

On a call using
the soft phone,
status changes
to:

Initial
Presence state
in Microsoft
Lync
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XAvailableAvailableOn the PhoneOn the
Phone/Custom

Available

AvailableInactive / IdleAvailableOn the Phone/CustomOn the
Phone/Custom

Inactive / Idle

AvailableAway / IdleAvailableAway/IdleOn the
Phone/Custom

Away / Idle

XBe right back/ManualBe right back/ManualBe right back/ManualBe right
back/Manual

Be right back
/Manual

XOff work / ManualOff work / ManualOff work / ManualOff
work/Manual

Off work
/Manual

XAppear Away /
Manual

Appear Away /
Manual

Appear Away /
Manual

Appear Away /
Manual

Appear Away
/ Manual

XAvailableAvailableOn the Phone /
Custom

On the Phone /
Custom

Busy / Manual

AvailableBusy Idle(5 min) -
Busy

AvailableBusy Idle (5 min) -
Busy

On the Phone /
Custom

Busy Idle (5
min) - Busy

AvailableBusy Idle (10 min) -
Away

AvailableBusy Idle (10 min) -
Away

On the Phone /
Custom

Busy Idle (10
min) - Away

XAvailableAvailableOn the Phone /
Manual

On the Phone /
Manual

On the Phone
/ Manual
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XDo not Disturb /
Manual

Do not Disturb /
Manual

Do not Disturb /
Manual

Do not Disturb /
Manual

Do not Disturb
/ Manual

This table describes the expected behavior in Microsoft Lync when Cisco UC Integration for Microsoft Lync is used for calls.

The different behavior when using a soft phone and desk phone for the inactive state is because when the
user responds on a soft phone when their machine is inactive, it will immediately become active.

Note

Presence Issues

Presence showing Busy not On the Phone

Problem Description: When on an active call, Busy presence is showing instead of On the Phone.

Resolution: Cisco UC Integration for Microsoft Lync provides an On the Phone custom presence xml file, for information on
configuring the registry keys see the Custom Presence Status in the Cisco UC Integration for Microsoft Lync 10.6 Administration
Guide.

Presence Not Changing as Expected

Problem Description: When on an active call, Cisco UC Integration for Microsoft Lync doesn't change status.

Resolution: Cisco UC Integration forMicrosoft Lync changes status in certain scenarios, see the Presence Behavior section for further
information.

Presence Not Showing In a Meeting

Problem Description: When a meeting is started and the meeting is shown in the meetings tab, the presence doesn't change.

Resolution: Microsoft Lync controls the presence changing to In a meeting. Verify the following:

• Verify that Microsoft Lync is connected with the Microsoft Lync server.

• Verify that the Exchange Web Service (EWS) is deployed to Lync.

• Check the values for the Microsoft Lync server parameters:

• CalendarStatePublicationInterval

•WebServicePollInterval

For further information check your Microsoft Lync documentation.

Presence not Changing

Problem Description: Using a desk phone to make a call and presence doesn't change

Resolution: When you are using a desk phone your computer can be in Idle state. See the Presence Behavior section for more
information on states and presences.
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Expected Presence When On a Call and In a Meeting

Problem Description: When on a call and in a meeting what is the expected presence.

Resolution: In Cisco UC Integration for Microsoft Lync the presence statuses In a Meeting, On the Phone and Busy have the same
priority, this is treated the same in Microsoft Lync. The last presence set is the last presence shown.

Overrides Manual Presence

Problem Description: Manually changing presence to Away doesn't change to On the Phone when on a call, but manually changing
presence to Busy and on a call will change the status to On the Phone.

Resolution: In Cisco UC Integration for Microsoft Lync the presence status Away has priority over the presence statuses In a Meeting,
On the Phone, and Busy.
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