
 

Cisco Configuration Professional Express 
3.5.x User Guide

First Published: June 26, 2018
Last Updated: August 13, 2018

Overview
The Cisco Configuration Professional Express (Cisco CP Express) is an embedded, device-management tool that 
provides the ability to bootstrap and provision a Cisco Industrial Router (IR). 

Cisco CP Express helps you to set up a network with complete WAN and LAN configurations, along with wireless access 
and security features. Security features are supported only if the IOS version is 15.5(1)T and later and the security license 
is enabled. For IR 800 Series routers, the recommended IOS version is 15.6(3)M2.CCP Express provides you two options 
to bring up a new router. You can use the Quick Setup Wizard to perform the basic configuration tasks and Advanced 
Setup option for detailed configuration options. For a new router, Quick Setup Wizard is the preferred option. 

When you are running CCP Express for the first time, you can use the Quick Setup Wizard to perform the basic router 
configuration tasks including setting up WAN, configuring LAN, and basic security configuration. 

All the configuration done through CCP Express is saved into startup configuration by default. When you use CCP Express 
for configuring a device, do not delete or modify the configuration directly by logging onto the device which will lead to 
misconfiguration. The Security tab is enabled only when the security license is enabled on the device and the IOS image 
is 15.5(1)T and later. For IR 800 Series routers, the recommended IOS version is 15.6(3)M2.

Verifying CP Express Installation
1. Connect the PC to the router by using an Ethernet cable as shown in Figure 1.
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Loading CCP Express
Figure 1 Connecting PC to the Router

2. Verify the Cisco CP Express is installed correctly by performing the following steps:

a. Launch the browser.

b. In the address bar, type the IP address of the router where Cisco CP Express is installed.

For example, type http://10.10.10.1 or https://10.10.10.1

c. Provide the one-time user credentials when the router prompts for specifying new username and the password.

d. Click Log In.

e. Create a new user account and login with the new user credentials. Cisco CP Express Installation screen 
launches.

Loading CCP Express
Splash Screen is displayed when CCP Express is loading. This screen gives information about the current release and a 
link to the feature guide.

27
20

98

WAN

FE 4

Cisco 861W
2



  
Cisco Configuration Professional Express 3.5.x User Guide

Loading CCP Express
Figure 2 Splash Screen

The Analytics Notification window displays with information about usage data.

Figure 3 Analytics Notification

1. Click Yes to continue. 

If the device is new, the Quick Set Up Wizard displays along with Advanced Setup. If the device is already configured, 
the home page with the list of Advanced options is displayed.
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Using Quick Setup Wizard
Figure 4 Quick Setup Wizard & Advanced Setup 

2. Click Quick Setup Wizard from the Quick Setup Wizard & Advanced Setup page to run the Quick Setup Wizard.

If you click on the Advanced Setup, you are taken to the CCP Express Landing page as shown in Figure 26 on 
page 17.

Using Quick Setup Wizard 
Quick Setup Wizard helps you to perform the basic router configuration when you are running the Cisco CP Express for 
the first time. 

Figure 5 Cisco CP Express Installation

Go through the configuration pre-requisites in the Quick Setup Wizard welcome screen, and then click Get Started. 

Note: Since the IR 809 does not support Wi-Fi, this option is not available on the IR 809 Quick Setup Wizard.
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Basic Setup
1. Configure basic settings by entering Router Name, Domain Name, and selecting the appropriate Time Zone. 

Figure 6 Quick Setup Basic Setup Screen

2. Click Next to access the primary WAN Configuration window.

WAN Configuration
See the following subtasks for each WAN option for configuring the required WAN:

 Cellular WAN Configuration

 Ethernet WAN Configuration

Cellular WAN Configuration 
1. Select the connected cellular WAN interface for configuring the primary WAN.

2. Select enable persistence if you want to establish a persistent connection to your service provider from the dialer 
interface.

3. Get DNS server information directly from ISP is selected by default. If this option is enabled you cannot assign IP 
addresses statically.

4. Select the SIM for activation. If you enable the auto firmware switch option to automatically switch over the firmware 
when you switch the SIM cards. 
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Using Quick Setup Wizard
Figure 7 Cellular Primary WAN Interface IR 829 Dual LTE

5. Click Next to configure the Backup WAN.

6. Check the Enable Backup WAN box.

7. Select WAN Connection Type as 3G/4G. For dual LTE, the Interface is Cellular 1/0 (SIM 1). See Figure 8.

For single LTE, the Interface is only Cellular. See Figure 9.
6



  
Cisco Configuration Professional Express 3.5.x User Guide

Using Quick Setup Wizard
Figure 8 Cellular Backup WAN Configuration IR 829 Dual LTE

Figure 9 Cellular Backup WAN Configuration IR 829 Single LTE

Ethernet WAN Configuration
1. In Primary WAN, select the Ethernet (Direct/PPPoE) as the WAN Connection Type. The Interface defaults to 

Gigabitinterface0.

Get DNS Server info directly from ISP is checked. 

2. Select the appropriate IP address configuration information based on whether you are configuring an IPv4 or IPv6 
address. 
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Using Quick Setup Wizard
a. Specify the details for the IP address depending on whether the IP address is dynamically or statically assigned. 
There is an option to enable NAT configuration, and it is recommended to enable NAT for WAN interfaces. The 
IPv6 address can be either AutoConfig, Use Prefix from Provider, or Static IP Address.

b. If you have selected AutoConfig, enable the Act as an IPv6 DHCP client option. 

c. If you have selected Prefix from Provider or Static IP Address option, enter Prefix and Prefix Mask details. 

3. If you have enabled PPPoE, select the required authentication mode. You have PAP and CHAP options.

4. Enter the user name and password provided by the service provider. 

5. Click Next.

Figure 10 Ethernet Primary WAN Configuration IR 829 

6. Select Enable Backup WAN option if you want to configure Back Up WAN. Follow the configuration steps 1 through 
5, and then click Next. 
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Using Quick Setup Wizard
Figure 11 Backup WAN Configuration IR 829 

7. Click Next to complete the LAN configuration since the DHCP pool will be automatically configured. You can use the 
same DHCP pool for the LAN network.

LAN Configuration
1. Select Change LAN network to edit the existing network. 

Figure 12 LAN Configuration Page

You will get a confirmation alert message before changing the existing network. Click OK to proceed.

2. If you want to add a new LAN network, select the add a new LAN network option.

3. Configure the new network with Pool Name, Pool Network, Subnet Mask, Default Gateway, and IP Address.
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Using Quick Setup Wizard
Figure 13 Configuration with LAN Network 

4. Click Next to configure IOx.

IOX Configuration
1. Click Enable IOX Access.

Figure 14 IOX

Note: If NAT is not enabled on the WAN, the following message appears:
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Using Quick Setup Wizard
Figure 15 NAT Alert Message

2. Click OK. Return back to the WAN page and enable NAT.

3. Click Next until you return to the IOX page.

4. Click Enable IOX Access. The button turns green for On.

Figure 16 IOX Configuration Page

5. If you want to change the IOX configurations, click Change IOX Config.
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Using Quick Setup Wizard
Figure 17 Change IOX Configuration

6. Click Next to configure WiFi if you have an IR 829. Otherwise, click Next to configure Security.

Wi-Fi Configuration (only on IR 829 Routers)
Note: If you have an IR 809, you do not see this option.

1. Click Turn on Wi-Fi. 

Figure 18 Wi-Fi

2. Provide the Network Name, Security type, and password (for WPA and WPA2) to be configured as SSID on the AP.
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Figure 19 Wi-Fi Configuration

3. Click Next.

Security Configuration
By default, Enable firewall features and Enable Application Visibility & Control are not checked. If you require these 
security settings:

1. Select Enable firewall features and then select create policy which allows basic traffic option to configure the security 
features.

2. Select Enable Cisco recommended security settings and then click Next.

Figure 20 Security Configuration

3. Click Submit to confirm the configuration changes in the summary screen.
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Using Quick Setup Wizard
Figure 21 Confirmation Screen (IR 829)

Figure 22 Confirmation Screen (IR 809)

A message appears saying configuration may take some time to configure and whether you want to continue the 
configuration. 

4. Click Yes to continue the configuration changes. 

Configuration using the Quick Setup Wizard is complete and a completion message appears. 
14
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Using CCP Express Advanced Mode
Figure 23 Configuration Completion using Quick Setup Wizard 

5. (Optional) If you want to check the status of your WAN connection, click Test WAN Connection.

Figure 24 Test WAN Connection

Using CCP Express Advanced Mode
This section explains how to configure Cisco IR routers using CCP Express advanced mode. The screens and 
configuration steps may slightly vary depending on the WAN configuration options and the software features supported 
by the Cisco IR routers. 

The Advanced Mode contains the following options:

 CCP Express Home Page, page 16

 General Settings, page 17

 DHCP/DNS, page 21

 Interfaces, page 24

 Identity, page 30
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Using CCP Express Advanced Mode
 Static Routing, page 33

 Dashboard, page 35

 Troubleshooting, page 42

 Access Control Lists (ACLs), page 44

 IOx, page 48

 Wireless, page 52

 Security Features, page 54

CCP Express Home Page
Once the configuration is pushed, you will be automatically redirected to the Dashboard page in the Advanced Settings 
section.

CCP Express by default loads in the New UI from version 3.5.1 onwards. User can switch back to the old UI by using the 
Option in Preferences-> Classic View. All existing features are arranged under 4 groups on the left: Dashboard, 
Configuration, Administration and Troubleshoot. The quick access utility pages/options are on the top right. 

Figure 25 New UI in Release 3.5.1 and Later Releases

You can switch between the two UIs using the option in Preferences section.

Below are samples of the old UI.
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Figure 26 CCP Express Home Page (IR 829) 

You can get to the CCP Express Home page by clicking on Advance Mode after going through the Quick Setup Wizard 
or by clicking the home icon on the right side of the page:

Figure 26 shows CCP Express home page where you can navigate to all the features.

Note: Since the IR809 does not support Wi-Fi, the Wireless option is not available.

General Settings
Click this option to configure Device and Time.

If you used the Quick Setup Wizard to configure your router, the device settings shown in Figure 27 are automatically 
listed here. If not, enter the Host name and Domain name.
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Using CCP Express Advanced Mode
Figure 27 Device Settings

Use the Time tab to change the timezone. You can also synchronize to the NTP server or make the router an NTP master.

Figure 28 Time Settings

SNMP Configuration
To enable SNMP configuration:

1. Go to General Settings

2. Click the SNMP Tab. 

All options are available under different tabs once SNMP is enabled on the box.
18
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Using CCP Express Advanced Mode
Figure 29 General SNMP Settings

Figure 30 SNMP Communities

Figure 31 SNMP V3 Users

Figure 32 SNMP Host
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Gyroscope
Gyroscope is used to determine the position of the device. 

1. Go to General Settings

2. Click the Gyroscope Tab. 

Figure 33 Gyroscope

3. Click the Enable Gyroscope.

4. Select the Reading frequency from the menu.

5. Click Apply.

HTTP/HTTPS Configuration
Http/Https configuration is available under General Settings -> HTTP/HTTPS tab. 

Note: This feature is available in Release 3.5.1 and later.
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Using CCP Express Advanced Mode
Figure 34 HTTP/HTTPS Configuration

DHCP/DNS
In this area, you can configure the following options:

 DNS

 DDNS

 DHCP

 DHCP Excluded Addresses
21
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Using CCP Express Advanced Mode
DNS

Figure 35 Primary and Secondary DNS 

DDNS
If you have not completed setting up your WAN interface, you see the following message:

DHCP

Figure 36 DHCP 

Configuring a LAN with DHCP 
Perform the following steps to create a DHCP pool.

1. Click DHCP/DNS and DHCP to open the DHCP tab.

2. From the DHCP interface, click Add to create a new DHCP pool by specifying:
22



  
Cisco Configuration Professional Express 3.5.x User Guide

Using CCP Express Advanced Mode
 Pool Name:—The name of the DHCP pool.

 Pool Network:—The IP address of the subnet that represents all IP addresses allocated to the wired or wireless 
clients.

 Subnet Mask:—The subnet mask.

 Import all DHCP options in to the DHCP server database: Check this check box to import all DHCP options into the 
DHCP server database. This ensures that the DNS is read from your service provider and is propagated to all DHCP 
clients.

Figure 37 Add DHCP Pool

3. Click OK to create the DHCP pool.

DHCP Excluded Addresses
To configure DHCP Excluded Addresses:

1. Click DHCP/DNS and DHCP to open the DHCP tab.

2. Click Add to create a new pool with the excluded addresses. Or, click Edit to add the excluded addresses to an 
existing pool.
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Using CCP Express Advanced Mode
Figure 38 Configure DHCP Excluded Addresses

3. Enter the Start and End DHCP excluded addresses. Ensure the start address value is smaller than the end address 
value.

To edit an existing DHCP Excluded Address:

1. Click DHCP/DNS and DHCP Excluded Addresses tab.

2. Select the address, and click Edit.

Figure 39 Edit a DHCP Excluded Address

3. Specify the IPv4 address which is the starting for the range to be excluded. 

4. Specify the IPv4 address which is the end of range to be excluded. 

5. Click OK.

To delete an existing DHCP Excluded Address:

1. Click DHCP/DNS and DHCP Excluded Addresses tab.

2. Select the address, and click Delete. See Figure 39.

Interfaces
Use this option to configure primary and/or backup for Ethernet and Cellular interfaces.
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Figure 40 Interfaces List

The Zones link takes you to the Zones page under the Security option. See Figure 73 on page 54.

Setting Up a Primary Ethernet WAN Interface
1. Click Interfaces to open the Interfaces page.

2. Select the GigabitEthernet Interface you want to configure and click Edit. The Edit GigabitEthernet Configuration 
page is displayed.
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Using CCP Express Advanced Mode
Figure 41 GigabitEthernet Interface Configuration

3. Select Primary WAN Interface from Primary Secondary Interface tab.

4. From the Connection & Routing tab, check Enable PPPoE check box, and enter the description in the description 
field. For IPv4 Routed Protocol, you may configure Ipv6oE with options of Bridge or DHCP configuration. 

5. From the Connection tab, check Enable PPPoE check box, and enter the description in the Description field.

6. Based on whether you are configuring an IPv4 or IPv6 address, select the appropriate tab. Specify the details for the 
IP address depending on whether the IP address is dynamically or statically assigned.

For configuring an IPv4 address:

This can be either Easy IP (IP Negotiated), Static IP Address, or No IP Address. By default, the IPv4 address is IP 
negotiated. There is an option to enable NAT configuration and the recommendation is to enable NAT for WAN 
interfaces. This will create NAT overloading configuration hence all LAN IPs are translated to public IP before being 
sent to WAN uplink.

For configuring an IPv6 address:

Select the IPv6 address type. The IPv6 address can be either AutoConfig, Use Prefix from Provider, Static IP 
Address, or No IP Address.

7. From the Authentication tab, check CHAP or PAP check box and specify the username and password given by 
Service provider.

8. Click OK to confirm the configuration. 

Setting up a Primary Cellular Interface
1. Click on the cellular interface you want to create as a primary.
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Figure 42 Edit Cellular Interface

2. Select Primary WAN Interface.

3. (Optional) Enable NAT.

4. (Optional) Select Move to WAN Zone to add this interface to a zone. If you select this option, the following message 
appears:

5. Click Yes to continue.

6. If you want to establish a persistent connection to your service provider, select Yes. By default, this is set to No to 
disable persistent connection.

7. Click OK.

In the main Interfaces list, the Primary WAN Interface is green and lists the primary interface.
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Figure 43 Configured Cellular Primary Interface

Setting up a Backup Cellular Interface
1. Click on the cellular interface you want to create as a primary.
28
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Figure 44 Edit Cellular Interface

2. Select Backup WAN Interface.

The SLA Configuration box displays. 

3. (Optional) Enter the IP address of a reliable website to check connectivity.

4. (Optional) Enable NAT.

5. (Optional) Select Move to WAN Zone to add this interface to a zone. If you select this option, the following message 
appears:

In the main Interfaces list, the Backup WAN Interface is green and lists the backup interface.
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Using CCP Express Advanced Mode
Figure 45 Configured Cellular Backup Interface

Create VLANs (only for IR 829)
Note: VLANs are not supported on IR 809.

1. Click Add VLAN to open the Add VLAN dialog box and specify a unique ID for the VLAN being created.

2. From the IPv4 address tab, choose Select from DHCP, and then select the DHCP pool from the drop-down list.This 
enables you to assign the IP addresses from the DHCP pool that is created.

or

Select Static IP to assign a unique IP address to the VLAN.

3. Click OK to confirm the configuration. 

Identity
Identity awareness is a key requirement for any Security solution. It is defined as the ability of the device to be aware of 
end-user identities. Also this supports User and Group management that allows administration of user authentication and 
authorization profiles using either local or external service.

Authentication
To configure authentication:

1. Click Identity > Authentication. 

2. In Authentication Servers section, select the local or remote option.
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— Enable local (on-box) server—Router acts as the local authentication server.

— Enable remote (external) server—Active Directory is supported.

If remote option is selected, the ADD new server option appears. 

a. Click ADD new server.

b. Enter the LDAP details: IP address of the server and Base DN information. Click OK.

Note: You can choose to configure both the server options. If both are configured, first attempt with authentication 
is with the remote server. If the remote server is not reachable, authentication falls back to the local server.

3. In the Authentication Services section, you can select Web Auth or NTLM.

The authentication method can be chosen for different zones, but in the current release only LAN zone is supported. 
If LAN Zone is configured, all interfaces coming under LAN zone are configured accordingly. NTLM option is 
supported only for remote server option. If the you configure both on-box and remote server options, selecting NTLM 
option is not allowed. 

Figure 46 Authentication Page
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Figure 47 Add/Edit LDAP Page

Managing User Groups 
To create or delete user groups or to see the list of created user groups:

1. Click Identity > Groups. The list of available groups is displayed.

2. Click Add. Enter the user name in the popup.

3. Enter the group name to be created.

Figure 48 Group Management Page

4. To delete any group, select the check box and click on Delete and confirm.

Managing Users
Steps to create a new user and associate/dissociate a user with a group are listed below:

1. Click Identity > Users. All created user names are listed. (Figure 49)

2. Click Add. The add user popup is displayed. 
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3. Enter the user details and click Ok.

Figure 49 User Management Page

Figure 50 Add User Page

Static Routing
The Static Routing feature allows you to add, edit, and delete IP routes to a destination interface, or IP address from your 
IPv4 or IPv6 subnets.

This section contains:
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 Creating a Static Route, page 34

 Editing a Static Route, page 35

 Deleting a Static Route, page 35

Creating a Static Route
To create a static route:

1. Click Static Routing to open the Static Routing page.

Figure 51 Static Routing

2. Click Add to open the Add Static Routing dialog box with options to specify an IPv4 or IPv6 static route.

Figure 52 The Static Routing page

3. Based on whether the IP address is an IPv4 or IPv6 address, select the IPv4 or IPv6 tab, and specify the following:

 Destination address: Specify the prefix and prefix mask for your IPv4 or IPv6 address.
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 Next Hop IP:
If you select Interface as the next hop IP, select the forwarding interface from the drop-down list.
If you select IP as the next hop IP, specify the Next Hop IP that must be used.
You can also specify DHCP address.

4. Click OK to add the static route.

Editing a Static Route
To edit an existing static route:

1. Click Static Routing to open the Static Routing page.

2. From the list of static routes, select the static route you want to edit, and click Edit.
The Edit Static Routing page is displayed.

3. Specify these fields for your static route:

 Destination address: specify the prefix and prefix mask for your IPv4 or IPv6 address

 Next Hop IP:
If you select Interface as the next hop IP, select the forwarding interface from the drop-down list.
If you select IP as the next hop IP, specify the Next Hop IP that must be used.

4. Click OK to edit the static route.

Deleting a Static Route
To delete a static route:

1. Click Static Routing to open the Static Routing page.

2. From the list of static routes, select the static route you want to delete, and click Delete.

Dashboard
The Dashboard view shows the vital hardware health status of the router along with the flash and system memory, CPU 
utilization, and WAN Interface status and security aspects of network. The Dashboard has two sections Router and 
Security. 

Viewing Router Dashboard
To view the router diagnostics using the dashboard view, perform these steps:

1. Click on Dashboard> Router to open the Router Diagnostics dashboard view.
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The Dashboard page

Hardware Health section shows the total Power Consumption of the router, Number of Fans on the system and their 
status, CPU Temperature and Battery health. If the router does not expose its hardware information, then this section will 
not be visible in the UI.

If Primary and Backup WAN Interfaces are configured, then the status of the same is displayed along with the interface 
Name. The status is shown in green only when both admin and operational status are up. This also shows the amount of 
traffic flowing through WAN Interfaces.

Note: The following sections have been moved to the System Information Popup: Hostname, Device Type, IOS Version, 
System Uptime from last reload, current System Time, and the Reason for Last Reload of the router. The Interfaces chart 
is moved under the Interfaces tab.

Beginning with CCP Express Release 3.5.2, for IR829M series devices, the Flash Memory dashlet will display two radio 
buttons: “flash” and “mSata.” The flash option retains the current dashlet data which is the pie chart that shows used 
and free space on the flash memory. If you select the mSata option, the used and free data of the SSD is displayed. You 
can hover on the flash icon and get the remaining lifetime for the SSD also. 

Figure 53 Flash Memory Dashlet

2. To update the charts, click on the refresh button given at the top of the charts section.
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CPU Utilization Dashlet
To access the new CPU Utilization dashlet:

1. Go to the Router Dashboard.

2. Under the CPU dashlet, click Details.

A new dashlet is shown in a popup dialog. The details of CPU usage are in percents for different intervals available in the 
new dashlet. 

Security Dashboard
To view the security dashboard view, perform these steps:

1. Click on Dashboard> Security to open the Security dashboard view.
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Figure 54 Security Dashboard (Dashlets displayed are Top 10 Applications and Top Users) 

Figure 55 Security Dashboard (Dashlets displayed are VPN, Policy, Top 10 Threats and IPS Drilldown) 
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Figure 56 Security Dashboard (Dashlets displayed are Firewall Drop and CWS Connections) 

The top portion shows the security features enabled on the device. The green icon indicates they are enabled. User can 
click on a specific icon and navigate to that feature. If any security feature is not enabled, then the relevant charts are not 
visible. They will be minimized and shown in the tray above the pane which is showing the security features ennoblement 
status. To close any chart click on the close button of the chart and the chart will be minimized into the tray. The icons 
can be clicked to enable it again.

Security Snapshot
 Applications Detected—Total number of Application protocols discovered by NBAR. While moving the mouse over, 

the list of applications will be displayed.

 Number of Active Users—Top users contributing to the traffic currently traversing the device.

 Tunnel Details—Hover over this option to list the VPN tunnels present along with the status (up or down).

 WAN Zone Bandwidth—Traffic going through the WAN Interfaces.

 IPS Victims—Total number of users impacted by some attack. The information is obtained by enabling the IPS feature.

Security Charts
Following is the list of various charts supported to show the security information and bandwidth consumption statistics 
of the network. These charts will update periodically. The refresh interval can be modified.

 Top Applications—This dashboard will list the top 10 application protocols contributing to the traffic through the 
router in terms of bandwidth consumption at any point of time. This chart will also provide the cumulative bandwidth 
consumption of the device from the time of router reload. CCP Express will get the update from device at configured 
regular intervals. 

 Top Users—This dashboard will list the top users in the router in terms of bandwidth consumption at any point of time. 
It supports both current bandwidth consumption.

 VPN—VPN chart shows encrypted and decrypted traffic through the configured VPN tunnel.

 Policy—Policy chart shows the amount of data that matched a specific Firewall Policy configured on the device. This 
gives the snapshot view of which policy is hit the most in the network.

 Top Threats—This dashboard shows the Top 10 threats in the network in terms of malicious packets. 

 IPS Drilldown—This dashboard shows the total attacks made by the attackers and attacks received by the victims. 

 Firewall drop—This dashboard shows the Top 10 firewall drops and the cause of the drops. 
39



Cisco Configuration Professional Express 3.5.x User Guide

 

Using CCP Express Advanced Mode
Application Visibility and Control (AVC) Dashboard
To view the AVC dashboard, perform these steps:

1. Click Dashboard> AVC to open the AVC dashboard view.

2. Enable AVC, a screen appears where you can drag and drop the interfaces to AVC interfaces. 

Figure 57 Configuring AVC

3. Click OK. Figure 58 displays. This page displays all the applications and the relevant data. At a time 8 applications 
are listed in the page. You can filter applications using the search option.

Figure 58 AVC Dashboard 

4. You can also click Settings icon to add or remove interfaces for AVC.

5. If security is enabled, you can block the applications in AVC screen. Select the applications and click BLOCK. Select 
the Source and Destination Zone and click OK. (Figure 59). Selected application will be blocked. When an application 
is blocked, a policy is automatically created by the name avc-app-block-1. The subsequent blocking of applications 
will add policies with the same name format with only the numbering incremented.
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Figure 59 Blocking Applications

Interfaces Dashboard
To view the Interfaces dashboard, perform these steps:

1. Click Dashboard> Interfaces to open the Interfaces dashboard view.

Interfaces chart groups the Interfaces by type and shows the number of interfaces that are up and down. If the user 
moves the cursor over the chart, then the specific interfaces will be displayed as tool tip.

Figure 60 Interfaces Dashboard 
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Troubleshooting
This section explains how to perform troubleshooting for your router.

This section discusses:

 “Ping and Traceroute” section on page 42

 “Test WAN Connection” section on page 42

Ping and Traceroute
The Ping and Traceroute utility allows you to do a basic troubleshooting of the network and device connectivity.

To troubleshoot the device connectivity, perform these steps:

1. Click Troubleshoot to open the Ping and Traceroute tab.

Figure 61 Ping and Traceroute 

2. (Optional) Specify the source IP address (IPv4 or IPv6 address) or interface.

3. Specify the destination IP address (IPv4 or IPv6 address) or hostname.

4. Click Ping to verify whether the destination IP address is reachable.

5. Click Traceroute to view the list of routes traversed between the source and destination IP addresses.

6. You can also copy-to-clipboard or download the retrieved data by clicking on COPY or DOWNLOAD icons to the 
right of the details box.

Test WAN Connection
If you do not have a primary interface configured, the following message appears:
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If a primary interface is configured without an IP address, the following information appears:

If a primary interface is configured with an IP Address and DNS details, the following information appears:
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For a successful connection, the following information appears:

Access Control Lists (ACLs)
Filter traffic and control access to the IP network using the ACL option from the main menu.
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Figure 62 ACL Summary

This page includes the Map ACL and Add ACE buttons for each ACL. Hover over the icons on the right to remove an ACL, 
expand and collapse an ACL. 

Add an ACL
To add an ACL:

1. From the Summary screen, click Add. 
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Figure 63 Add ACL

2. Select the standard option from the Type menu and provide an ACL Name/Number (0-99 for standard).

3. Select the ACL Rule to permit or deny.

4. Select the IP address option with either ‘any’ or ‘valid IP address and wildcard Mask’.

You can also add mappings while adding the ACL through this window.

Add an Extended ACL
1. From the Summary screen, click Add. 

2. Select the extended option from the Type menu and provide an ACL Name/Number (0-100 for extended).
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Figure 64 Add an Extended ACL

3. Select a protocol. For TCP/UDP, select the source port and destination port from the lists.

Map an ACL
To map an ACL:

1. Select the ACL, and click Map ACL. Existing mapping values are listed under one ACL. 
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Figure 65 Map ACL

2. Select Interface and add its route.

or

Select the VTY route, and add the VTY value.

Note: HTTP option will be enabled only for Standard numbered ACL.

Add an Access Control Entry (ACE)
To add an ACE, click the ACE.

Figure 66 ACE

IOx 
Use this option to access IOx services through the local management interface.

If IOx is not configured on the router, the following message displays:
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After you configure IOx on the router, select IOx from the Home menu.

Depending on your configuration, you can access IOx Manager through LAN or WAN. 

Click either option to launch the Local Manager.

Figure 67 IOx Management 

Guest OS Functions
Use this window to start, stop, or restart Guest OS

Figure 68 Guest OS Stopped
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Figure 69 Guest OS Start

Guest OS Upgrade
1. Click IOX from the main menu.

2. Select the Guest OS Upgrade tab to view the existing Guest OS images on the device.

3. To upload a Guest OS image, click the Desktop option. 

Figure 70 Guest OS Upgrade

4. Click on the link to download the latest Guest OS version. You are taken to the Cisco.com download page. 

5. Download the recommended latest version for the device.

If you do not have a Cisco.com login, ensure you register.

After you upload the file, the following message displays:
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6. Click Select Guest OS image file, and choose the Guest OS file from the folder in which you downloaded it. 

7. Click on Upload Guest OS File. 

8. Proceed with the upload of the file to the box by clicking Yes. If the upload fails, click TRY AGAIN.

Once the upload is completed, the application automatically comes back to the Guest OS Update main page which 
lists all the available IOS images on the router. 

9. Choose the Guest OS image you would like to add to the boot list. 

10. Click Update Guest OS to install the new version
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Figure 71 Guest OS Upload Completed

For more information about IOx, refer to the IOx documentation at the following URL:

http://www.cisco.com/c/en/us/support/cloud-systems-management/iox/tsd-products-support-series-home.html

Wireless
Wireless configuration is done through the Wi-Fi Manager which is external to CCP Express.

When you click Wi-Fi, you receive the following message with a link to Wi-Fi Manager:

1. Click Launch Wi-Fi Manager. 

2. Select Network Configuration under the Easy Setup menu.
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Figure 72 Wi-Fi Manager (External to CCP Express)

For more information about configuring access points, refer to the Cisco IOS Configuration Guide for Autonomous Aironet 
Access Points documentation at:

http://www.cisco.com/c/en/us/td/docs/wireless/access_point/15_2_4_JB/configuration/guide/scg15-2-4-Book.html

3. Specify an SSID that will be used to uniquely identify your wireless device.
The SSID can contain up to 32 alphanumeric characters.

4. To broadcast the SSID in the access point beacon, check the Broadcast SSID in Beacon check box.
When you broadcast the SSID, devices that do not specify an SSID can associate with the access point. This is a 
useful option for an SSID used by guests or by client devices in a public space. If you do not broadcast the SSID, 
client devices cannot associate to the access point unless their SSID matches this SSID. Only one SSID can be 
included in the access point beacon.

5. Select the Enable VLAN ID and specify the ID of the VLAN.
This will enable the clients that connect to the SSID to use the IP addresses from the DHCP pool associated with this 
VLAN.

6. Select the security setting for the SSID.

 Static WEP Key: choose the WEP key index and key size, and enter the static WEP encryption key. The key index 
can be between 1 and 4. The key size can be either 40 bits or 128 bits.

 WPA2: specify the WPA2 encryption key and select the key type. The Key type can be either ASCII or Hexadecimal.

7. Click Apply.
The SSID appears in the SSID table on the bottom of the page.
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Security Features
This section includes the following:

 Zones, page 54

 Policy, page 54

 IPS, page 58

 VPN, page 63

 Content Security, page 82

 Static NAT, page 83

Zones
Zones establish the security borders of your network. A zone defines a boundary where traffic is subjected to policy 
restrictions as it crosses to another region of your network. ZFW’s default policy between zones is deny all. If no policy 
is explicitly configured, all traffic moving between zones is blocked.

 Click Security > Zones. The left side list shows the list of available interfaces which can be moved to appropriate 
security zones. The supported zones are WAN, LAN, VPN, and DMZ.

 If any interface needs to be moved to any security zone, it can be just dragged and dropped into the zone. WAN and 
VPN zones are grayed out here and moving the WAN interface under WAN zone can be done in interface screen. 
Also when VPN is configured, the respective Tunnel interface will be moved to VPN zone internally.

Figure 73 The Zones Page

Policy
With the Zones and Policy pages configured, users can enable Zone based Firewall on the device. Policy page applies 
user-defined rules or policy on the traffic that flows between source and destination zones. The source and destination 
zones are tied together to make a zone pair under which the policy is applied. Prior to creating and applying policy, user 
needs to configure and assign the interfaces under the right zones.

Policy feature provides more granularity in identifying and filtering the traffic. Within the traffic between source zone and 
destination zone, the user can filter the traffic further based on the source and destination network, application type, the 
source and destination ports, domains, and the user groups. 
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Policy Summary 
To view the policy summary, perform these steps:

1. Click Security >Policy to display the summary screen of Policy. The summary screen lists all existing policies and 
option to add, edit and delete an existing policy

— The Policy display in the summary screen is based on the zone pairs. For e.g in the picture below there are two 
groups of policies and the groups based on zone pairs viz. LAN-WAN and LAN-VPN 

— The order of policies can be changed by just dragging and dropping the policies within the zone pair section 
table. The changes can be reverted by clicking the arrow icon placed on top of the zone pair section

Figure 74 The Policy Page

Prerequisite for Creating Any Policy
 Prerequisite for creating a policy is assigning the specific interfaces to Zones. 

 Provide Zone link here

Some sample use case scenarios are explained below

Block a Specific Application
To block a specific application, perform these steps:

1. Click Security > Policy, and click Add. The Policy Dialog appears.

2. From the Policy Dialog, provide Policy Name, description, and the source and destination zones whose traffic needs 
to be processed. Also, the action needs to be taken on the selected traffic whether we need to block it or allow it. 

3. Click Network. Add source and destination network if any specific network within the zone-pair is to be handled. 
Add the source network by specifying the network in the text field and add plus button. The same procedure needs 
to be followed for any destination network as well. By default, source and destination network would be 
‘any’.(Figure 75)
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Figure 75 The Security Policy Wizard (Landing screen with Network tab contents) 

4. Click Application to select the application to be inspected or blocked. The Available Applications shows the list of 
applications grouped as per the known category. The needed application or group can be dragged and dropped in 
the Selected Applications list.

Figure 76 The Security Policy Wizard (Application tab contents) 

5. Click Ports if it is required to classify the application based on source and destination ports. By default, traffic 
originating from any ports of the selected networks will be processed. User can add a required source and 
destination ports. List of popular applications is given based on their Category and by dragging and dropping the 
needed one will handle the port specific to that.
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Figure 77 The Security Policy Wizard (Ports tab contents) 

6. Click User Groups if the traffic filtering is to be handled based on the user or group originating the traffic. 

Figure 78 The Security Policy Wizard (User group tab contents) 

Block a Specific Domain
To block a specific domain, perform these steps:

1. Click Security > Policy, and click Add.

2. Policy Dialog will appear. Provide Policy Name, description, and the source and destination zones whose traffic 
needs to be processed. Also the action needs to be taken on the selected traffic whether we need to block it or allow 
it. 

3. Click Network. Add source and destination network if any specific network within the zone-pair is to be handled. 
Add the source network by specifying the network in the text field and add plus button. The same procedure needs 
to be followed for any destination network as well. By default all the networks in the Zone pair is processed. 
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Figure 79 The Security Policy Wizard (Landing screen with Network tab contents) 

4. Click Domain Filtering and the screen shows list of popular sites. User can drag and drop if any of the popular 
websites need to be blocked. If any unlisted domain needs to be added that URL (wild card pattern accepted) can 
be given in the text box.

Figure 80 The Security Policy Wizard (Domain Filtering tab contents) 

5. Click User Groups if the traffic filtering is to be handled based on the user or group originating the traffic. 

Note: To select the specific User group it should have been already added through the Identity feature.

IPS
Cisco IOS Intrusion Prevention System (IPS) is an inline, deep-packet inspection feature that effectively mitigates a wide 
range of network attacks. A component of the Cisco IOS Integrated Threat Control framework and complemented by 
Cisco IOS Flexible Packet Matching feature, Cisco IOS IPS provides your network with the intelligence to accurately 
identify, classify, and stop or block malicious traffic in real time.
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Prerequisites for Using IPS
 Ensure the IPS Signature Packages are present on the router under flash:

 Enable Security License on the router.

 Complete WAN interface configuration.

If these conditions are not met, respective error messages are displayed when the IPS feature is accessed.

Enabling IPS
If all the prerequisites are met, you receive the option to enable IPS.

1. Click Security > IPS, and choose the Enable IPS check box.

2. When you enable IPS for the first time, a popup window lists all of the IPS Signature Packages available on the box. 
The first one is selected by default. Even if there is only a single package, you get this dialog box. 

Figure 81 IPS Signatures

3. Select appropriate one and click OK.

4. You get the message that there are changes to IPS configuration. Upon applying the changes, IPS is enabled on 
inbound traffic (depicted in the image below the check box). The selected signature package is compiled and 
applied too. To view the interface(s) on which this will be applied, hover on the image to view the tool tip containing 
that information.
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Figure 82 Intrusion Prevention System Page

5. Click on the Apply button to persist changes. You have to wait for a minute (depending on the signatures selected) 
as the signature compilation is occurring in the background.

6. After the settings are applied and the signature compilation is completed, the IPS screen with the information on the 
package version and count of failed signatures (if any) is displayed.

Note: For all further disable/enable cycles, you are not prompted to select the package. In those cycles, after 
enabling, you get a message that “Signature compilation is in progress”. You can choose to visit other pages and 
come back later or to hit “Refresh” after a while to see the IPS settings screen.

Disabling IPS
To disable IPS at any point, uncheck the Enable IPS check box and click Apply.

Uploading IPS Signature Packages
You have the option to upload signature packages onto the router at any point in time. To upload IPS signature packages, 
perform these steps:

1. Hover your cursor over the Configure icon that is available on the right pane. The settings menu appears. 

2. Click on the Upload IPS Signature Packages option. A dialog box appears. 

3. Click on the Folder button and select the file from the file selection dialog box and click OK.

CCP Express validates for the file name, duplication and free space on the router. If any of these validations fail, 
appropriate error message are displayed. If the file validations are completed, you receive the message that file is 
ready for upload and the “Upload” button is enabled. 

4. Click on the Upload button to initiate the upload.

Upload takes a while as the file size is around 20MB. You are notified when the upload is completed. You can upload 
more files or quick the dialog. 

 

60



  
Cisco Configuration Professional Express 3.5.x User Guide

Using CCP Express Advanced Mode
Changing IPS Signature Packages
When IPS is enabled, if the box has more than one Signature Package file, you are provided with an option to change the 
signature package. To change IPS signature packages:

1. Hover your cursor over the Configure icon that is available on the right pane. The settings menu appears. 

2. Click on the Change IPS Signature Packages option.

A dialog box with the list of available packages on the box is displayed. The currently selected one is listed, but 
selection is disabled for this one. The packages are sorted in reverse alphabetical order to have the latest one at the 
top for easy selection. 

3. Select the package of your choice and click OK. Signature compilation may take several seconds. 

4. After the settings are applied and signature compilation is completed, the IPS screen with the information on the 
newly selected package version and count of failed signatures (if any) is displayed. 

Download Link for IPS Signature Packages
You can download the relevant signature package files from the link that is shared with you. This is a link that connects 
you to an internal CISCO page. To download IPS signature package: 

1. Hover your cursor over the Configure icon that is available on the right pane. The settings menu appears. 

2. Click on the Download IPS Signature Packages option. Upon clicking on the link, you are taken to the CISCO IPS 
Services page (external to CCP Express), from where the you can download signature packages that are needed.

Enabling/Disabling Notifications/Log
You are provided with links to enable and disable SDEE and syslog notifications. The menu is smart to toggle between 
the enable and disable options for each based on the setting in the system.

SDEE Notifications 
To enable SDEE notifications:

1. Hover mouse on the Configure icon that is available on the right pane. The settings menu appears.

2. Click on the Enable SDEE Notifications option.

3. After the setting is applied, the menu item changes to Disable SDEE Notifications. This is because in the device, it 
is enabled. If you click on this option again, it toggles the state on the device as well as on the menu. 

Syslog
Use this section to check the Syslog on the device. This feature is available in CCP Express Release 3.5.2 and later 
releases.

To enable Syslog:

1. Click Troubleshoot and navigate to the Log option.
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Figure 83 Syslog View

2. Enter the number of lines to be displayed and click on “Show Logs”. Once logs are listed user can search for a 
particular string and all the occurrences will be highlighted.

Figure 84 Syslog - Show Logs

3. You can also configure Syslog servers.
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Figure 85 Syslog Servers

VPN
CCP Express supports creation of IPSec multi-site VPN configuration, DMVPN spoke side configuration, DMVPN hub 
configuration, remote access configuration, a combination of IPSec multi-site with remote access configurations, and a 
combination of DMVPN hub with remote access VPN configurations.

Prerequisite for VPN
Primary WAN interface must be configured and should be part of WAN Zone. Also, LAN interfaces should be part of LAN 
Zone before configuring any VPN.

IPSec Multi-Site Configuration
To configure multi-site VPN:

1. Click Security > VPN and select IPsec option from the VPN Configuration drop-down list.

2. Click the Enable VPN check box and click Add Site. The VPN wizard is displayed as a popup dialog.
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Figure 86 IPSec Multi-Site VPN

3. Provide Tunnel IP and Mask for the site being configured.

Figure 87 IPSec Multi-Site VPN (Tunnel Configuration)

Note: By default, from configuring site end, all the LAN side networks are allowed to access the other end through VPN 
tunnel.

4. Provide the remote peer address (WAN IP address of the other end).
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Figure 88 IPSec Multi-Site VPN (Remote Configuration)

5. Select an appropriate Key Exchange model (either IKEv1 or IKEv2). By default, IKEv2 is selected and that is 
recommended. 

6. Provide Pre shared Key.

Figure 89 IPSec Multi-Site VPN (Profile)

7. (Optional) Select Advance to manually configure IKE and IPSec parameters. 
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Figure 90 IPSec Multi-Site VPN (Advanced Options)

8. Click Finish.

After the configuration is complete, the list of sites is displayed. You can choose to add more or delete sites from the 
available list.

Figure 91 IPSec Multi-Site VPN (Completed)

Note: If CCP Express is used to configure the Multi-Site VPN, ensure that both the ends are configured with CCP Express 
only. CCP Express internally uses the transform set as esp-aes, esp-sha-hmac and IKEv2 Proposal with encryption as 
3des, integrity as md5 and Diffie Helman group as 2.
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DMVPN Spoke Configuration
To enable DMVPN Spoke configuration:

1. Click Security > VPN and select DMVPN Spoke option from the VPN Configuration drop-down list.

2. Click Enable DMVPN Spoke check box, and click Configure.

Figure 92 DMVPN Spoke Configuration

3. Provide Tunnel IP, Backup Tunnel IP, and Tunnel Mask for site being configured.

4. Provide the Remote Tunnel Address (WAN IP address of the other end). You can also provide the FQDN of the Hub 
device. Click Next.
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Figure 93 DMVPN Spoke Configuration (VPN Peers)

By default from configuring site end all the LAN side networks are allowed to access the other end through VPN 
Tunnel.

When DMVPN Spoke configuration is successfully completed, and the Hub is configured and active, the tunnel will 
come up between Hub and Spoke. 

5. Select an appropriate Key Exchange model (either IKEv1 or IKEv2). By default, IKEv2 is selected and is 
recommended. 

6. Provide the Pre-Shared Key.
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Figure 94 DMVPN Spoke Configuration (VPN Profile)

Figure 95 DMVPN Spoke Configuration (VPN Profile Advanced Options)

7. Provide an EIGRP Autonomous number in the range of 1–65535.
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Figure 96 DMVPN Spoke Configuration (Routing)

8. Click Finish.

Figure 97 DMVPN Spoke Configuration (Completed)

DMVPN Hub Configuration
To configure DMVPN Hub:

1. Click Security > VPN and select DMVPN Hub option from the VPN Configuration drop-down list.

2. Click Enable DMVPN Hub check box, and click Configure.
70



  
Cisco Configuration Professional Express 3.5.x User Guide

Using CCP Express Advanced Mode
Figure 98 DMVPN Hub Configuration

3. Provide Tunnel IP and Mask for the hub being configured.

Figure 99 DMVPN Hub Configuration (VPN Peers)

4. Select an appropriate Key Exchange model (either IKEv1 or IKEv2). By default, IKEv2 is selected and is 
recommended. 

5. Provide the Pre-Shared Key.
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Figure 100 DMVPN Hub Configuration (VPN Profile)

Figure 101 DMVPN Hub Configuration (VPN Profile Advanced Options)

6. Provide the routing configuration.

7. Provide an EIGRP Autonomous number in the range 1–65535. 
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Figure 102 DMVPN Hub Configuration (Routing)

8. Click Finish.

Figure 103 DMVPN Hub Configuration (Completed)

Remote Access VPN Configuration
To configure Remote Access VPN, perform these steps:

1. Click Security > VPN and select Remote Access VPN option.

2. Click the Enable Remote Access VPN check box, and click Configure.
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Figure 104 Remote Access Configuration

3. Provide Pool Name and the range of IP Addresses for the pool. 

Figure 105 Remote Access Configuration (Pool)

4. Provide the Pre shared Key.

Note: By default, Remote Access VPN configuration supports only IKEv1 Key Exchange model and IP Sec enabled 
L2TP protocol.
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Figure 106 Remote Access Configuration (VPN Profile)

5. Select the Crypto Map interface.

Figure 107 Remote Access Configuration (Mapping)

6. Click Finish.
75



Cisco Configuration Professional Express 3.5.x User Guide

 

Using CCP Express Advanced Mode
Figure 108 Remote Access Configuration (Completed)

IPSec Multi-Site and Remote Access VPN Configuration Combination
To configure the combination of IPSec Multi-Site and Remote Access VPN configurations:

1. Click Security > VPN and select IPSec VPN + Remote Access option from VPN Configuration option.

2. Click the Enable IPSEC + Remote Access VPN check box, and click Configure.

Figure 109 IPSec Multi-Site and Remote Access Configuration Combination

3. Provide Tunnel IP and Mask for the site being configured. 
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Figure 110 IPSec Multi-Site and Remote Access Configuration Combination (Tunnel)

Note: By default, from configuring site end, all the LAN side networks are allowed to access the other end through VPN 
tunnel.

4. Provide the Remote Peer Address (WAN IP address of the other end) information.

Enter the pool information, Preshared Key, and Crypto Map Interface.

Figure 111 IPSec Multi-Site and Remote Access Configuration Combination (Remote)

5. Ensure that the IKEv2 is selected. 

Note: IKEv2 is the only key exchange method available.
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Figure 112 IPSec Multi-Site and Remote Access Configuration Combination (VPN Profile)

Figure 113 IPSec Multi-Site and Remote Access Configuration Combination (Advanced Options)

Note: If CCP Express is used to configure the Multi-Site VPN, ensure that both the ends are configured with CCP Express 
only. CCP Express internally uses the transform set as esp-aes, esp-sha-hmac and IKEv2 Proposal with encryption as 
3des, integrity as md5 and Diffie Helman group as 2.

6. Click Finish.
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Figure 114 IPSec Multi-Site and Remote Access Configuration Combination (Completed)

DMVPN Hub and Remote Access Configuration Combination
To configure the combination of DMVPN Hub and Remote Access VPN configurations: 

1. Click Security > VPN and select the DMVPN Hub + Remote Access VPN option from the VPN Configuration 
drop-down list.

2. Click Enable DMVPN Hub + Remote Access VPN check box, and click Configure.

Figure 115 DMVPN Hub and Remote Access Configuration Combination

3. Provide Tunnel IP and Mask for the hub being configured.

Enter the pool information, Preshared Key, and Crypto Map Interface.
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Figure 116 DMVPN Hub and Remote Access Configuration Combination (VPN Peers)

4. Ensure that the IKEv2 is selected. 

Note: IKEv2 is the only key exchange method available.

5. Provide the Pre-Shared Key.

Figure 117 DMVPN Hub and Remote Access Configuration Combination (VPN Profile)
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Figure 118 DMVPN Hub and Remote Access Configuration Combination (VPN Profile Advanced Options)

6. Provide the routing configuration.

7. Provide an EIGRP Autonomous number in the range 1–65535. 

Figure 119 DMVPN Hub and Remote Access Configuration Combination (Routing)

8. Click Finish.
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Figure 120 DMVPN Hub and Remote Access Configuration Combination (Completed)

Content Security
Cloud based 'Security as a Service’ (SecaaS) such as Cloud Web Security (CWS) is a scalable means to provide 
market-leading web security to quickly and easily protect the network from web-based threats, such as Malware, while 
saving bandwidth, money, and resources. CWS provides Anti-X functionality (anti-malware, anti-bot, anti-virus, and 
anti-phishing) on ISR-G2 itself without the need for expensive Security Appliances in branch, small offices. 

To configure content security, perform these steps:

1. Click Security > Content Security.

2. Provide Primary CWS Server IP address or DNS resolvable hostname and Secondary server information.

3. Provide the license key received from CWS service provider and specify if it is an encrypted or unencrypted key.
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Figure 121 Content Security Page

Edit Content Security
After CWS is fully configured and the tower is reachable, a green tower icon displays as shown in the screen below. 
Otherwise, the tower is displayed in red.

Figure 122 Content Security Page

Static NAT
Static NAT creates a fixed translation of unregistered real address to mapped registered address. Also with port 
forwarding option, it is possible to open ports in response to inbound traffic for a specified service.
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To create a static NAT:

1. Click Security > Static NAT. To add a Static NAT, click Add. A dialog box opens. 

Figure 123 Static NAT Page

2. Provide the Internal IP address which needs to be translated and the external IP address or Interface. 

3. If you need to send the traffic to specific port, click Enable Port Forwarding check box, and select the type of port, 
for example TCP or UDP. If the port type is not known, select Any option which supports both the type of ports. 

4. After selecting the ports, specify the internal and external ports.

Figure 124 Edit Static NAT Page

More Options - Top Menu Small Icons
You can perform the following tasks by hovering over the icons on the right side of the page:
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 System Information, page 85

 Configure CLI, page 85

 Save Configuration, page 86

 Running Configuration Download, page 87

 Options Menu, page 87

 Upgrade CCP Express, page 90

 Upgrade IOS, page 94

System Information
To access the basic system information winder, click the “info” icon (i) on top right.

Figure 125 System Information

Configure CLI
The Configure CLI feature allows you to configure or run any IOS CLI commands that can be directly executed from the 
router’s command prompt.

To configure a CLI, perform these steps:

1. Click the Configure CLI icon  to open the CLI configuration page.

2. From the Configure CLI tab, select the mode in which you want to execute the CLI.
You can select either the Exec or Configure mode.

Note: If you issue multiple commands, the output is listed for each command as shown in a terminal window with 
the command followed by the output.
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Figure 126 An example of a command executed in Config mode

Figure 127 An example of a command executed in Exec mode

3. In the text box, type the CLI you want to execute.

4. Click Run Command to execute the CLI. The CLI’s output is displayed.

5. You can also copy-to-clipboard or download the retrieved data by clicking on COPY or DOWNLOAD icons to the 
right of the details box.

Note Using the Configure CLI feature, you cannot configure interactive commands and service module related 
commands.

Save Configuration
Save Configuration helps you check and sync the difference between the running and startup configs. To access the Save 
Configuration window, click the save button on the top right. 
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Figure 128 Save Configuration 

This window lists the Startup Configuration. Click Save and Apply Configuration to apply the Startup Configuration. 

Running Configuration Download
Click on Running Config icon allows you to save the running configuration to memory.

Options Menu
Note: This Options menu is only available in the old UI. The new UI has these features on top right side and also in main 
menu options.

In the upper right side, click the  icon to display the More Options window.
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Figure 129 More Options

Note: The Quick Setup Wizard icon appears only if the device is factory fresh. 

Preferences

Figure 130 Preferences 

Enable Usage Activity Collection
Turning this option On allows Cisco to collect data on the usage patterns of the Device Manager. Cisco only collects data 
on the usage patterns and does not collect network or configuration data.
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Cisco Recommended Security Settings
Turning this option On ensures all passwords are encrypted and are not shown in plain text.

Feedback
Use this option to provide your user experience to Cisco. Let us know how we can improve the product.

Help
Help takes you to this feature guide on Cisco.com.

Cisco Active Advisor
The Cisco Active Advisor feature provides the essential life cycle information about your network inventory. Cisco Active 
Advisor also helps to reduce network’s overall risks by updating the status of the products in the network periodically. 
Cisco Active Advisor shows the following information:

 Warranty and service contract status

 Product advisories, including Product Security Incident Response Teams (PSIRTs) and field notices

 End-of-Life notifications for hardware and software

The CAA feature is available in More Options. 

This section contains:

 Uploading the Configuration, page 89

 Viewing the Device Details, page 90

Uploading the Configuration
To upload the router configuration, perform these steps:

1. Click Cisco Active Advisor to open Cisco Active Advisor page.

2. Enter your CEC username and password in the Product Improvement tab

Figure 131 Product Improvement tab 

3. Click Authenticate & Upload.
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Viewing the Device Details
1. Click Connect to Cisco Active Advisor tab, 

2. Click Inventory and Lifecycle to view the device details.

Figure 132 Connect to Cisco Active Advisor tab

Upgrade CCP Express 
To upgrade the CCP Express, follow these steps:

1. Click on Options menu on the page header.

2. Select Upgrade option. The Upgrade CCP Express page is displayed. (Figure 133)
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Figure 133 Upgrade CCP Express

3. Click on the link to download the latest CCP express version. It navigates to CCO page. If you do not have a CCO 
login, register it.

4. If you already have a zip/Admin tar in your PC, skip the above step.

5. Click on CCP Express Tar File and choose the tar file from the folder where it is extracted. 

6. After selecting the tar, click on Upgrade CCP Express and it asks for confirmation as shown. (Figure 134)

Figure 134 Upgrade Confirmation 

7. Click YES to confirm Upgrade CCP express. It takes time to upgrade and below page will be displayed. (Figure 135)
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Figure 135 Upgrade CCP Express

8. If upgrade fails, click TRY AGAIN. (Figure 136)

Figure 136 Upgrade CCP Express

9. After upgrading the CCP Express, it automatically takes you to the Landing Page with updated version. If you are 
using the UI prior to Release 3.5, you see the Landing Page in Figure 137.
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Figure 137 Upgrade CCP Express

If you are using the UI in Release 3.5 or greater, you see the Landing Page in Figure 138.

Figure 138 New UI in Release 3.5
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Upgrade IOS
Upgrade IOS when you are notified of a new IOS release.

1. Click on Options icon on the page header.

2. Select IOS Update option. The IOS Update page is displayed as shown in Figure 139.

Figure 139 IOS Update

3. Upload the image to the device by selecting Desktop. 
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Figure 140 IOS Update Page

4. If you do not have the latest IOS image, click the link in IOS Update window. You are taken to the IOS Download page 
with the latest images.

5. Go back to the IOS Update window, and follow the instructions in the Upload section.

6. From the Router (Flash) window, select the IOS image and click Update IOS. The following message appears:

7. Click Yes.

Using CCP Express in Restricted Access Mode (Monitor User)
The Monitor User feature addition allows a user of privilege 14 to login to CCP Express with restricted access. The only 
features available to this user would be Dashboard (Router & Interfaces), any CLI, and Troubleshoot. 

Note: This feature is available in Cisco CCP Express Release 3.5.1 and greater releases.

Prerequisites
 IOS version 15.7(3)M2 or greater
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 Privilege 14 (already installed) 

To access CCP Express as a monitor user:

1. Clear cache from the browser and then relaunch it.

2. Access CCP Express by using the IP address or the friendly URL. 

3. Enter your login credentials, and enter the Privilege 14 level user’s credentials. This is the Monitor User.

The splash screen displays after you enter the credentials.

Figure 141 Monitor User Splash Screen

Based on the Admin User’s preference for the UI, the Monitor User is be presented with Old UI (Figure 142) or New UI 
(Figure 143). 

Figure 142 Old UI Landing Page for Monitor User
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Figure 143 New UI Landing Page for Monitor User

Under Dashboard, Monitor User can access the Router Dashboard (Figure 144) and Interfaces Dashboard (Figure 145).

Figure 144 Router Dashboard for Monitor User
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Figure 145 Interfaces Dashboard for Monitor User

Under the Troubleshoot Dashboard, the Monitor User can access the Ping and Traceroute (Figure 146) and Test WAN 
Connection (Figure 147).

Note: Specifying the source is not available for the Monitor User.

Figure 146 Ping and Traceroute for Monitor User
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Figure 147 Test WAN Connection for Monitor User

Monitor User can also access the Syslog Views.

Figure 148 Syslog View
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Figure 149 Syslog - Show Logs

Monitor User can issue commands using the Any CLI feature. Monitor User has privilege 14 which is allowed only to 
execute a subset of the show commands available for privilege 15 users. Monitor User has only the Execute option and 
not the Config option as compared to the Admin User. 

Monitor User can view the system information (Figure 150) by clicking on the info button on top right side.

Figure 150 System Information for Monitor User
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Monitor User Management (for Admin User)
A user logged into CCP Express with privilege 15 level access is an Admin User who is authorized to use all features and 
operations within CCP Express. Since Monitor User has lesser privilege and read-only access, Admin User is given the 
provision to manage the Monitor User from the Monitor View tab under Identity.

To manage Monitor Users:

1. Login as an Admin user, and navigate to Identity -> User.

2. If the IOS version is 15.7(3)M2 and greater and Monitor User is not enabled, you will see the Enable Monitor User 
button available (Figure 151). 

Figure 151 Enable Monitor Users

3. Click the Enable Monitor User button, and the config required to support Monitor User gets pushed. 

Whether Monitor User support was enabled manually by the Admin User or was configured on the device already, the 
data listed in User tab will list the type of user.
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Figure 152 Users Tab

The Monitor View tab shows a list of Monitor Users as well as the commands pertaining to CCP Express which are 
available to the Monitor User. 

Figure 153 Monitor View Tab

Admin User can enable new commands for the Monitor User using the Add Commands button. The commands are 
validated before those are enabled for monitor user. 
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Figure 154 Enable New Commands for Monitor User

Friendly URL
To Access CCP Express using a friendly URL:

1. Connect the device directly to the laptop or desktop.

2. Open a browser, and enter “myir800.com”.

You are directed to the CCP Express application.

Figure 155 CCP Express UI
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Related Documentation
IR 800 Series documentation:

http://www.cisco.com/c/en/us/support/routers/800-series-industrial-routers/tsd-products-support-series-home.html

Release Notes for Cisco Configuration Professional Express 3.5.x:

https://www.cisco.com/c/en/us/support/routers/800-series-industrial-routers/products-release-notes-list.html

Cisco Configuration Professional Express Quick Start Guide:

https://www.cisco.com/c/en/us/support/routers/800-series-industrial-routers/products-installation-guides-list.html

Cisco Configuration Professional Express 3.5 Administration Guide:

https://www.cisco.com/c/en/us/support/routers/800-series-industrial-routers/products-installation-and-configuratio
n-guides-list.html
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