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Introduction

Introduction

Use this guide to configure Cisco Secure Network Analytics (formerly Stealthwatch) and
the Cisco AnyConnect Secure Mobility Client Network Visibility Module (NVM) to allow:

» Storage of AnyConnect NVM fields
» Viewing the NVM fields

» Existing policy violation rules to trigger from NVM flows

I A\ Secure Network Analytics with NVM supports UDP, but it does not support DTLS.

e Secure Network Analytics v7.4.x with Cisco Secure Network Analytics Endpoint
license. For more information about Endpoint license, refer to the Smart Software
Licensing Guide 7.4

» AnyConnect Secure Mobility Client v4.7 and later

Remove Endpoint Concentrator

Starting in v7.3.2, the Endpoint Concentrator is not needed for the Endpoint

o License deployment, and the Flow Collector was enhanced to process Network
Visibility Module (NVM) data on all Secure Network Analytics deployments,
including Data Store.

If you are an existing Secure Network Analytics customer upgrading from 7.3.0 or 7.3.1 to
7.4.1, you will need to remove the Endpoint Concentrator and reconfigure your NVM
deployment.

Remove your Endpoint Concentrator(s) and configure your Flow Collector using the
following instructions:

1. Remove your Endpoint Concentrator(s) from your cluster using Central
Management.
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a. Open Central Management.

b. On the Appliance Manager page, click the (missing or bad snippet) in the
Actions column for the Endpoint Concentrator.

c. Select Remove This Appliance, then click Yes.

2. Configure flows from the NVM client to the Flow Collector using the Configure
NVM profile on AnyConnect Secure Mobility Client section.

3. Update your cluster to v7.4.1 using the Secure Network Analytics Update Guide
(v7.3.xtov7.4.1).

4. Add the NVM processing port to your Flow Collector Advanced Settings using the
Configure the Flow Collector section.

5. Verify NVM data is processed using Report Builder or Flow Search using the
Verification section.

| 0 For assistance, please contact Cisco Stealthwatch Support.

Report Builder

We moved Report Builder from a separate app to the core Secure Network Analytics in
v7.4.x. If you have a previous version of the app installed, your app will be removed
automatically as part of the update to Secure Network Analytics v7.4.x. Make sure you
follow the instructions in the Update Guide.

Do not uninstall your existing Report Builder app. If you uninstall Report Builder,
A\ all files associated with it, including your saved reports and temporary files, are
deleted.

You do not need to uninstall your existing app. If you uninstall Report Builder, all files
associated with it, including your saved reports and temporary files, are deleted. Do not
delete the Report Builder existing app.

Endpoint license is now supported for Cisco Secure Network Analytics Data Store and
provides:

» Full visibility to the endpoint, including on-network and off-network data

« Visibility to any NVM fields from the Endpoint Traffic (NVM) report in the Report
Builder app
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¢ A minimum of 30 days of storage of NVM data

* Improved processing and query performance

The following table provides performance estimates for a standard enterprise traffic
profile (most customers):

Flows per second (FPS)

Number of Number of

EC 4210s DS 6200s/ 31 Days
NetFlow NVM Storage
300,000 150,000 1 3

There are several factors that may affect your specific performance, such as
0 number of hosts, average size of flows, and more. While we do our best to

represent the data as fairly and accurately as possible, your environment may
experience different limits.
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Configure NVM profile on AnyConnect Secure Mobility Client

The AnyConnect Profile Editor is available through Cisco Adaptive Security

0 Device Manager (ASDM) or as a standalone offering. For more information about
how to use the AnyConnect Profile Editor, refer to the Cisco AnyConnect
Administrator Guide.

1. Verify you have installed the Network Visibility Module.

's Cisco AnyConnect Secure Mobility Client X

Cisco AnyConnect Secure Mobility Client
Version 4.9.04043
© Copyright 2004 - 2020 Cisco Systems, Inc. All Rights Reserved

Gsco, the Gsco Logo, Cisco AnyConnect, AnyConnect and the AnyConnect logo are registered trademarks
or trademarks of Cisco and/or its affiliates in the United States and certain other countries.

Installed Modules:
VPN, System Scan, Roaming Securty, Customer Experience Feedback[Network Visibilty]

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit:
https://www.openssl.org

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)

This product includes software written by Tim Hudson (th@cryptsoft.com)

This product incorporates the libcurl HTTP library:
Copyright (c) 1996 - 2019, Daniel Stenberg, (daniel@haxx.se).

NI
End User License Agreement
Cisco Online Privacy Statement and the AnyConnect Supplement c I sco

2. Open the Network Visibility Module Profile Editor.

3. Inthe Collector Configuration section, enter the IP Address and Port of your Flow
Collector.

We recommend you use port 2030 rather than the default port, 2055. If port
2030 is already in use, you may use any non-reserved port. You will use this port
@ in the Configure the Flow Collector section.

Do not use ports 2055, 514, or 8514.
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Collection Mode

Collection Criteria

Data Collection Policy

Trusted Network Detection ||

[ AnyConnect Profile Editor - NVM Profile - O *
File Help
NVM Profile Desktop v
Profile: Untitled
~
Collector Configuration Cache Configuration
IP Address/FQDN [ Max Size 50 MB
Port [] Max Duration days
Periodic Template Report | 1440 mins
Mote: Valid range: 5mins - 24hrs{1440mins).
Periodic Flow Report [ |s0 seconds
Mote: Valid range 60-360. To send at the start of the flow: 0.
Aggregation Interval 5 seconds
Throttle Rate 500 Kbps l}

Mote: Valid range: 12 - 2048, To disable: 0.

All Networks ~
[] Broadcast packets
[ Multicast packets

Add

Edit

Delete

@ Help

Open the VPN Profile

oSO 0N o g kM

— —

Click File > Save to save your NVM Profile.
Close the NVM Profile Editor.

Editor.

Click on Preferences (Part 2).
Check the Automatic VPN Policy check box.

For Trusted Network Policy, select Connect from the drop down.

For Untrusted Network Policy, select DoNothing from the drop down.

Enter your Trusted DNS Domains, Trusted Servers, and Certificate Hash.

e The Trusted DNS Domain should be the same domain that the Flow
Collector is running on. Wildcards (*) are supported for DNS suffixes.

e The Trusted Servers should be the IP addresses of the DNS servers on the

network.
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[B& AnyConnect Profile Editor - VPN O *
File Help
4
¥ ;gi | Preferences (Part 2)
; Preferences (Part 1) .
rofile: Untitled
“ Preferences (Part 2) DP
Badwp Servers Automatic VPN Palicy &
' Certificate Pinning Trusted Network Palicy Connect
Certificate Matching
=4 Certificate Enrollment Untrusted Network Policy DoMothing
Mabile Policy
...... Server List Trusted DNS Domains *,cisco.com
Trusted DNS Servers
Mote: adding all DNS servers in use is recommended with Trusted Metwork Detection
Trusted Servers @ https:/f<server=[: <port>]
https:/f Add
Delete
Certificate Hash: Set
[] Always On {More Information)
Allow VPN Disconnect
Connect Failure Policy Closed
Allow Captive Portal Remediation
Remediation Timeout {min.) 5
Apply Last VPN Local Resource Rules
[[] Captive Paortal Remediation Browser Failover v

6 Help

12. Click File > Save to save your preferences.

13. Close the AnyConnect Profile Editor.

Using First Time Setup (Data Store Only)

To enable ingest of NVM flows on a new Flow Collector, complete the following steps:

1.

Use the applicable Data Store appliance installation guide for your Flow Collector.
Follow the instructions to get to the Configuring your Environment using First Time

Setup section.

For more detailed instructions on appliance installation and configuration of multiple

telemetry types, use the Data Store appliance installation guide.

2. Access the virtual machine console. Allow the virtual appliance to finish booting up.

3. Login through the console.
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e Login: root

o Default Password: lan1cope

* You will change the default password when you configure the system.
4. Atthe command prompt, type SystemConfig. Press Enter.

5. Review the failed login attempts information. Select OK to continue.

6. Review the First Time Setup introduction. Select OK to continue.
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7. Select Network Visibility Module - NVM from the telemetry types list. Select Yes to
continue.

I 0 All telemetry types are selected by default.

8. Enter the UDP port for Network Visibility Module - NVM. Select OK.

Set the value to the port specified in step 2 of the Configure NVM profile on
0 AnyConnect Secure Mobility Client section. Port 2030 is the default port.
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I @ Do not use ports 2055, 514, or 8514.

9. Confirm your settings. Select Yes to continue.

10. Follow the on-screen prompts to finish the virtual environment and restart the
appliance.
Using the Flow Collector Advanced Settings

To enable ingest of NVM flows on a Flow Collector that has already been configured,
complete the following steps:
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1. Loginto your Manager.

2. From the navigation menu, click the It (Global Settings) icon and select Central
Management.

3. Click the *** (Ellipsis) icon for your Flow Collector, then click View Appliance
Statistics. The Flow Collector Admin interface opens.

4. Click Support > Advanced Settings.

5. In the enable_nvm field, set the value to 1.

ci_accelerator K | 0
condition_timeout 600 | =)
db_ingest_resume_threshold ‘ 5 | @]
disable_stealth_probe ‘ 0 | 0
domain_id 301 | O
enable_netflow E | a
[enabe_nvm ‘ 1 | ] O
enable_sal o | O
engine_startup_mode ‘ 0 | @]
exporter_inactivity_timeout ‘ 30 | @]
fc_id 301 | O

6. Inthe nvm_netflow_port field, set the value to the port specified in step 2 of the
Configure NVM profile on AnyConnect Secure Mobility Client section. For example,
port 2030.

If a field is not shown, scroll to the bottom of the page. Click the Add New
0 Option field. For more information about editing advanced settings on the Flow
Collector, refer to the Advanced Settings Help topic.
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max_service_bandwidth_pool 166
max_templates_pool 4 -
max_threshold_pool 172 O
max_valid_ping_len 90 O
min_asymmetric_flows 50 -
min_emails_per_period 30 O
min_threat_confidence_level 10 O
nvm_age_limit_days 0 =
[ nvm_netflow_port 2030 ] O]
process_old_nvm_flows 0 O
quiet_long_flow_duration 32400 -
quiet_long_flow_max 300000 O
restart_hour 4 O

7. Click Apply.
8. When the confirmation message is shown, click OK.

9. To configure the Flow Collector for Offline Data Collection, continue to the next
section. Do not close the Flow Collector.

Use the following instructions to configure cache flow processing for collecting off-
network NVM data.

Collecting off-network NVM data impacts system performance. Do not enable
this configuration if you do not need to collect or analyze this data.
0 If you enable the configuration and your system performance is impacted, adjust
the throttle rate (refer to the AnyConnect Administator Guide) and/or decrease
the nvm_age_limit_days (refer to the instructions in this section).

1. Before you start this procedure, make sure you finish the previous procedures. You
will continue this configuration in the Flow Collector engine Support > Advanced
Settings. If the Flow Collector is closed, log in to it directly, or:
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* Log in to your Manager.
* From the navigation menu, click the e (Global Settings) icon and select
Central Management.

e Click the *++ (Ellipsis) icon for your Flow Collector, then click View Appliance
Statistics. The Flow Collector Admin interface opens.

e Click Support > Advanced Settings.
2. Update the following fields:

» process_old_nvm_flows: Enter 1 to enable cached flows.

* nvm_age_limit_days: Enter the maximum number of days to collect cached
flows.
For example, if you enter 7, it collects the last 7 days. If you enter O (zero),
there is no limit. For best performance, set a limited number of days.

If a field is not shown, scroll to the bottom of the page. Click the Add New
0 Option field. For more information about editing advanced settings on the Flow
Collector, refer to the Advanced Settings Help topic.

3. Click Apply.

4. When the confirmation message is shown, click OK.
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Log in to your Manager.
Click Analyze > Flow Search.

Run a Flow Search.

PN~

On the Flow Search Results, filter the table by the Subject Process Name to verify
you are getting NVM flows.

Report Builder provides three NVM-related reports for Secure Network Analytics with a
Data Store:

 NVM Database Ingest Trend, provides a notification when your data has
successfully reached the database ingest
* NVM Collection Trend, shows flow rate arrival at the Flow Collector from NVM

« Endpoint Traffic (NVM), displays the most recent 300 records based on the end
time

For more information about these reports, click the o (Help) icon to access the
Help for Report Builder.

For example, to view the Endpoint Traffic (NVM) report:

Log in to your Manager.

Select the Dashboards menu.

Select Report Builder.

Click Create New Report and select Endpoint Traffic (NVM).
Click Run.

Verify the report is showing NVM fields.

I S o
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Contacting Support

If you need technical support, please do one of the following:

e Contact your local Cisco Partner
¢ Contact Cisco Support

» To open a case by web: http://www.cisco.com/c/en/us/support/index.html

» To open a case by email: tac@cisco.com
» For phone support: 1-800-553-2447 (U.S.)

e For worldwide support numbers:
https://www.cisco.com/c/en/us/support/web/tsd-cisco-worldwide-contacts.html
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